1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 DESCRIPTION="Cloudflare Tunnel client (formerly Argo Tunnel)"
7 HOMEPAGE="https://github.com/cloudflare/cloudflared"
10 https://github.com/cloudflare/cloudflared/releases/download/${PV}/cloudflared-linux-amd64
11 -> cloudflared-${PV}-amd64
14 https://github.com/cloudflare/cloudflared/releases/download/${PV}/cloudflared-linux-arm64
15 -> cloudflared-${PV}-arm64
18 https://raw.githubusercontent.com/cloudflare/cloudflared/refs/tags/${PV}/RELEASE_NOTES
19 -> RELEASE_NOTES-${PV}
25 KEYWORDS="-* amd64 ~arm64"
35 cp "${DISTDIR}/cloudflared-${PV}-amd64" cloudflared || die
38 cp "${DISTDIR}/cloudflared-${PV}-arm64" cloudflared || die
41 die "Unsupported arch ${ARCH}"
45 use doc && (cp "${DISTDIR}/RELEASE_NOTES-${PV}" release_notes || die)
50 doexe "${S}/cloudflared"
51 use doc && dodoc "${S}/release_notes"