1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 DISTUTILS_USE_PEP517=setuptools
7 PYTHON_COMPAT=( python3_{9..12} )
9 inherit systemd distutils-r1
11 DESCRIPTION="A Secure Socket Tunneling Protocol (SSTP) server implemented in Python."
12 HOMEPAGE="https://github.com/sorz/sstp-server/"
13 SRC_URI="https://github.com/sorz/sstp-server/archive/v${PV}.tar.gz -> ${P}.tar.gz"
17 KEYWORDS="amd64 arm mips x86"
19 DEPEND="net-dialup/ppp"
24 distutils-r1_src_install
29 systemd_newunit "${FILESDIR}/sstp-server_at.service" sstp-server@.service