remove ia64 keywords
[gentoo-zh.git] / sys-apps / aptly / aptly-9999.ebuild
blob513d6440cb5ded8b7be9803fe5e60abb32ead76f
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 EGIT_REPO_URI="https://github.com/aptly-dev/${PN}.git"
8 inherit bash-completion-r1 git-r3 go-module systemd
10 DESCRIPTION="A swiss army knife for Debian repository management"
11 HOMEPAGE="https://github.com/aptly-dev/aptly"
13 LICENSE="MIT"
14 SLOT="0"
15 RESTRICT="test" # fails
17 RDEPEND="
18 acct-group/aptly
19 acct-user/aptly
22 src_unpack() {
23 git-r3_src_unpack
24 go-module_live_vendor
27 src_compile() {
28 ego build -o cmd/aptly -ldflags "-X main.Version=${PV}"
31 src_test() {
32 ego test -work ./...
35 src_install() {
36 einstalldocs
37 dobin cmd/aptly
38 doman man/aptly.1
39 dobashcomp completion.d/aptly
40 insinto /usr/share/zsh/site-functions
41 doins completion.d/_aptly
42 systemd_dounit aptly-api.service
43 systemd_dounit aptly.service
44 newinitd "${FILESDIR}"/aptly.initd aptly
45 newconfd "${FILESDIR}"/aptly.confd aptly
46 newinitd "${FILESDIR}"/aptly-api.initd aptly-api
47 newconfd "${FILESDIR}"/aptly-api.confd aptly-api
49 diropts -o aptly -g aptly -m 0700
50 keepdir /etc/aptly
51 insopts -o aptly -g aptly -m 0644
52 insinto /etc/aptly
53 doins "${FILESDIR}"/aptly.conf