1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 K_WANT_GENPATCHES
="base extras"
7 #Note: to bump xanmod, check K_GENPATCHES_VER in sys-kernel/gentoo-sources
10 inherit check-reqs kernel-2
15 DESCRIPTION
="Full XanMod source, including the Gentoo patchset and other patch options."
16 HOMEPAGE
="https://xanmod.org"
19 XANMOD_URI
="https://download.sourceforge.net/xanmod"
22 ${KERNEL_BASE_URI}/linux-${KV_MAJOR}.${KV_MINOR}.tar.xz
24 ${XANMOD_URI}/patch-${OKV}${XANMOD_VERSION}.xz
26 S
="${WORKDIR}/linux-${OKV}${XANMOD_VERSION}"
32 CHECKREQS_DISK_BUILD
="4G"
33 check-reqs_pkg_pretend
38 mv "${WORKDIR}/${MY_P}" "${WORKDIR}/linux-${OKV}${XANMOD_VERSION}"
43 rm "${S}/tools/testing/selftests/tc-testing/action-ebpf"
44 # delete linux version patches
45 rm "${WORKDIR}"/*${MY_P}*.
patch
49 "${WORKDIR}"/patch-${PV}-xanmod${XANMOD_VERSION}
58 elog "Use xanmod-sources with microcodes
"
59 elog "Read https
://wiki.gentoo.org
/wiki
/Intel_microcode
"