remove ia64 keywords
[gentoo-zh.git] / sys-kernel / xanmod-sources / xanmod-sources-6.11.9-r1.ebuild
blob48632262dbe90c1167b2decc9d964982ba5467f1
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI="8"
5 ETYPE="sources"
6 K_WANT_GENPATCHES="base extras"
7 #Note: to bump xanmod, check K_GENPATCHES_VER in sys-kernel/gentoo-sources
8 K_GENPATCHES_VER="11"
10 inherit check-reqs kernel-2
11 detect_version
12 detect_arch
14 MY_P=linux-${PV%.*}
15 DESCRIPTION="Full XanMod source, including the Gentoo patchset and other patch options."
16 HOMEPAGE="https://xanmod.org"
18 XANMOD_VERSION="1"
19 XANMOD_URI="https://download.sourceforge.net/xanmod"
20 OKV="${OKV}-xanmod"
21 SRC_URI="
22 ${KERNEL_BASE_URI}/linux-${KV_MAJOR}.${KV_MINOR}.tar.xz
23 ${GENPATCHES_URI}
24 ${XANMOD_URI}/patch-${OKV}${XANMOD_VERSION}.xz
26 S="${WORKDIR}/linux-${OKV}${XANMOD_VERSION}"
28 LICENSE+=" CDDL"
29 KEYWORDS="~amd64"
31 pkg_pretend() {
32 CHECKREQS_DISK_BUILD="4G"
33 check-reqs_pkg_pretend
36 src_unpack() {
37 default
38 mv "${WORKDIR}/${MY_P}" "${WORKDIR}/linux-${OKV}${XANMOD_VERSION}"
41 src_prepare() {
42 kernel-2_src_prepare
43 rm "${S}/tools/testing/selftests/tc-testing/action-ebpf"
44 # delete linux version patches
45 rm "${WORKDIR}"/*${MY_P}*.patch
47 local PATCHES=(
48 # xanmod patches
49 "${WORKDIR}"/patch-${PV}-xanmod${XANMOD_VERSION}
50 # genpatches
51 "${WORKDIR}"/*.patch
53 default
56 pkg_postinst() {
57 elog "MICROCODES"
58 elog "Use xanmod-sources with microcodes"
59 elog "Read https://wiki.gentoo.org/wiki/Intel_microcode"
60 kernel-2_pkg_postinst
63 pkg_postrm() {
64 kernel-2_pkg_postrm