1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 PYTHON_COMPAT
=( python3_
{9.
.11} )
7 inherit meson python-any-r1 virtualx xdg
9 DESCRIPTION
="jonaburg's picom fork with dual_kawase blur and rounded corners"
10 HOMEPAGE
="https://github.com/jonaburg/picom"
11 SRC_URI
="https://github.com/jonaburg/picom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16 IUSE
="+config-file dbus +doc +drm opengl pcre test"
18 REQUIRED_USE
="test? ( dbus )" # avoid "DBus support not compiled in!"
19 RESTRICT
="test" # but tests require dbus_next
28 x11-libs/xcb-util-image
29 x11-libs/xcb-util-renderutil
32 dev-libs/libxdg-basedir
34 dbus? ( sys-apps/dbus )
35 drm? ( x11-libs/libdrm )
36 opengl? ( virtual/opengl )
37 pcre? ( dev-libs/libpcre )
42 BDEPEND
="virtual/pkgconfig
43 doc? ( app-text/asciidoc )
44 test? ( $(python_gen_any_dep 'dev-python/xcffib[${PYTHON_USEDEP}]') )
47 DOCS
=( README.md picom.sample.conf
)
49 S
="${WORKDIR}/picom-${PV}"
53 $
(meson_use config-file config_file
)
55 $
(meson_use doc with_docs
)
57 $
(meson_use pcre regex
)
64 virtx
"${S}/tests/run_tests.sh" "${BUILD_DIR}/src/${PN}"