remove ia64 keywords
[gentoo-zh.git] / x11-misc / snapd-xdg-open / snapd-xdg-open-20170401.ebuild
blobdffbc8cf6a231ed6a92c496ca364d59cb10c2dcd
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools
8 DESCRIPTION="Software for opening links from snaps in desktop"
9 HOMEPAGE="https://github.com/snapcore/snapd-xdg-open"
10 EGIT_COMMIT="6fed3570066ea93598e8091bf749352a02d482ad"
11 SRC_URI="https://github.com/snapcore/snapd-xdg-open/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm64 ~loong"
17 S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
19 src_prepare() {
20 default
21 eautoreconf
24 src_configure() {
25 econf --prefix=/usr \
26 --libexecdir=/usr/lib/"${PN}"
29 src_install() {
30 default
31 exeinto /usr/lib/"${PN}"
32 doexe src/xdg-open