remove ia64 keywords
[gentoo-zh.git] / x11-wm / hypr / hypr-1.1.4.ebuild
blob67f2a977d733922ede58e62677ddeaa4800c072d
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake toolchain-funcs
8 DESCRIPTION="A dynamic Linux tiling window manager for Xorg"
9 HOMEPAGE="https://github.com/hyprwm/Hypr"
10 SRC_URI="https://github.com/hyprwm/Hypr/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 S="${WORKDIR}/Hypr-${PV}"
17 DEPEND="x11-libs/cairo
18                 dev-build/ninja
19                 x11-libs/libxcb
20                 x11-base/xcb-proto
21                 x11-libs/xcb-util
22                 x11-libs/xcb-util-cursor
23                 x11-libs/xcb-util-keysyms
24                 x11-libs/xcb-util-wm
25                 dev-cpp/gtkmm:3.0
26                 gui-libs/gtk"
28 pkg_pretend() {
29         if ! tc-is-gcc; then
30                 ewarn "Only GCC is officially supported as compiler"
31                 ewarn "Proceed with your own caution"
32         fi
33         }
35 src_install() {
36         dobin "${BUILD_DIR}/Hypr"
37         dodoc "${S}/example/hypr.conf"