www-client/brave-bin: add 1.73.91, drop 1.73.89
[gentoo-zh.git] / app-office / anytype-bin / anytype-bin-0.43.6.ebuild
blob6e4672a8e0dbd6a20ca2f6b2569d6f075ec3f6b8
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit desktop xdg-utils
8 DESCRIPTION="A notebook based on p2p network"
9 HOMEPAGE="https://anytype.io"
10 SRC_URI="https://anytype-release.fra1.cdn.digitaloceanspaces.com/Anytype-${PV}.AppImage
11         https://anytype-release.fra1.cdn.digitaloceanspaces.com/anytype_${PV}_amd64.deb"
13 S="${WORKDIR}"
14 LICENSE="ASAL-1.0"
15 SLOT="0"
16 KEYWORDS="~amd64"
18 RESTRICT="strip"
20 RDEPEND="sys-fs/fuse:0"
21 BDEPEND="app-arch/dpkg"
23 QA_PRESTRIPPED="*"
25 src_unpack() {
26         cp "${DISTDIR}/Anytype-$PV.AppImage" anytype-bin || die
29 src_prepare() {
30         default
31         dpkg -x "${DISTDIR}"/anytype_${PV}_amd64.deb . || die "dpkg icon extraction failed"
32         sed -i 's|Exec=/opt/Anytype/anytype %U|Exec=anytype-bin %U|g' usr/share/applications/anytype.desktop ||
33                 die "Sed Exec command failed"
36 src_install() {
37         dobin anytype-bin
38         for size in 16 32 64 128 256 512 1024; do
39                 doicon -s "$size" usr/share/icons/hicolor/"$size"x"$size"/apps/anytype.png || die "Icon installation failed"
40         done
41         domenu usr/share/applications/anytype.desktop || die "Desktop file installation failed"
44 pkg_postinst() {
45         xdg_desktop_database_update
48 pkg_postrm() {
49         xdg_desktop_database_update