1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-misc/tint2/tint2-0.11-r1.ebuild,v 1.5 2012/09/11 17:38:41 idl0r Exp $
7 inherit cmake-utils eutils
9 if [[ ${PV} == "9999" ]] ; then
10 ESVN_REPO_URI
="http://tint2.googlecode.com/svn/trunk"
12 KEYWORDS
="~amd64 ~x86"
15 MY_P
="${PN}-${PV/_/-}"
16 SRC_URI
="http://tint2.googlecode.com/files/${MY_P}.tar.bz2"
18 S
="${WORKDIR}/${MY_P}"
21 DESCRIPTION
="A lightweight panel/taskbar"
22 HOMEPAGE
="http://code.google.com/p/tint2/"
26 IUSE
="examples tint2conf"
28 COMMON_DEPEND
="dev-libs/glib:2
34 x11-libs/libXcomposite
38 DEPEND
="${COMMON_DEPEND}
40 x11-proto/xineramaproto"
41 RDEPEND
="${COMMON_DEPEND}
42 tint2conf? ( x11-misc/tintwizard )"
45 if [[ ${PV} == "9999" ]] ; then
46 epatch
"${FILESDIR}/gtk-icon-cache.sandbox.patch"
48 epatch
"${FILESDIR}/battery_segfault.patch" # bug 343963
55 $
(cmake-utils_use_enable examples EXAMPLES
)
56 $
(cmake-utils_use_enable tint2conf TINT2CONF
)
59 "-DDOCDIR=/usr/share/doc/${PF}"
62 cmake-utils_src_configure
66 cmake-utils_src_install
67 rm -f "${D}/usr/bin/tintwizard.py"