app-admin/rbw: add 1.11.1, drop 1.11.0
[gentoo-zh.git] / app-admin / rbw / rbw-1.11.1.ebuild
blob23bbf19da93197cf9d817640e511e4395f0ca59c
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.2
6 EAPI=8
8 CRATES="
9         addr2line@0.22.0
10         adler@1.0.2
11         aes@0.8.4
12         aho-corasick@1.1.3
13         anstream@0.6.14
14         anstyle-parse@0.2.4
15         anstyle-query@1.1.0
16         anstyle-wincon@3.0.3
17         anstyle@1.0.7
18         anyhow@1.0.86
19         argon2@0.5.3
20         arrayvec@0.7.4
21         async-trait@0.1.80
22         autocfg@1.3.0
23         axum-core@0.4.3
24         axum@0.7.5
25         backtrace@0.3.73
26         base32@0.5.0
27         base64@0.22.1
28         base64ct@1.6.0
29         bitflags@1.3.2
30         bitflags@2.6.0
31         blake2@0.10.6
32         block-buffer@0.10.4
33         block-padding@0.3.3
34         block@0.1.6
35         bumpalo@3.16.0
36         byteorder@1.5.0
37         bytes@1.6.0
38         calloop-wayland-source@0.2.0
39         calloop@0.12.4
40         cbc@0.1.2
41         cc@1.0.101
42         cfg-if@1.0.0
43         cipher@0.4.4
44         clap@4.5.7
45         clap_builder@4.5.7
46         clap_complete@4.5.6
47         clap_derive@4.5.5
48         clap_lex@0.7.1
49         clipboard-win@3.1.1
50         colorchoice@1.0.1
51         concurrent-queue@2.5.0
52         const-oid@0.9.6
53         copypasta@0.10.1
54         core-foundation-sys@0.8.6
55         core-foundation@0.9.4
56         cpufeatures@0.2.12
57         crossbeam-utils@0.8.20
58         crypto-common@0.1.6
59         cursor-icon@1.1.0
60         daemonize@0.5.0
61         data-encoding@2.6.0
62         der@0.7.9
63         digest@0.10.7
64         directories@5.0.0
65         dirs-sys@0.4.0
66         dlib@0.5.2
67         downcast-rs@1.2.1
68         env_filter@0.1.0
69         env_logger@0.11.3
70         errno@0.3.9
71         fastrand@2.1.0
72         fnv@1.0.7
73         form_urlencoded@1.2.1
74         futures-channel@0.3.30
75         futures-core@0.3.30
76         futures-executor@0.3.30
77         futures-io@0.3.30
78         futures-macro@0.3.30
79         futures-sink@0.3.30
80         futures-task@0.3.30
81         futures-util@0.3.30
82         futures@0.3.30
83         generic-array@0.14.7
84         gethostname@0.4.3
85         getrandom@0.2.15
86         gimli@0.29.0
87         heck@0.5.0
88         hermit-abi@0.3.9
89         hermit-abi@0.4.0
90         hkdf@0.12.4
91         hmac@0.12.1
92         http-body-util@0.1.2
93         http-body@1.0.0
94         http@1.1.0
95         httparse@1.9.4
96         httpdate@1.0.3
97         humantime@2.1.0
98         hyper-rustls@0.27.2
99         hyper-util@0.1.5
100         hyper@1.3.1
101         idna@0.5.0
102         inout@0.1.3
103         ipnet@2.9.0
104         is-docker@0.2.0
105         is-terminal@0.4.12
106         is-wsl@0.4.0
107         is_terminal_polyfill@1.70.0
108         itoa@1.0.11
109         js-sys@0.3.69
110         lazy-bytes-cast@5.0.1
111         lazy_static@1.5.0
112         libc@0.2.155
113         libloading@0.8.4
114         libm@0.2.8
115         libredox@0.1.3
116         linux-raw-sys@0.4.14
117         lock_api@0.4.12
118         log@0.4.21
119         mach2@0.4.2
120         malloc_buf@0.0.6
121         matchit@0.7.3
122         memchr@2.7.4
123         memmap2@0.9.4
124         mime@0.3.17
125         miniz_oxide@0.7.4
126         mio@0.8.11
127         num-bigint-dig@0.8.4
128         num-integer@0.1.46
129         num-iter@0.1.45
130         num-traits@0.2.19
131         num_cpus@1.16.0
132         objc-foundation@0.1.1
133         objc@0.2.7
134         objc_id@0.1.1
135         object@0.36.0
136         once_cell@1.19.0
137         open@5.1.4
138         openssl-probe@0.1.5
139         parking_lot@0.12.3
140         parking_lot_core@0.9.10
141         password-hash@0.5.0
142         paste@1.0.15
143         pathdiff@0.2.1
144         pbkdf2@0.12.2
145         pem-rfc7468@0.7.0
146         percent-encoding@2.3.1
147         pin-project-internal@1.1.5
148         pin-project-lite@0.2.14
149         pin-project@1.1.5
150         pin-utils@0.1.0
151         pkcs1@0.7.5
152         pkcs8@0.10.2
153         pkg-config@0.3.30
154         polling@3.7.2
155         ppv-lite86@0.2.17
156         proc-macro2@1.0.86
157         quick-xml@0.31.0
158         quinn-proto@0.11.3
159         quinn-udp@0.5.2
160         quinn@0.11.2
161         quote@1.0.36
162         rand@0.8.5
163         rand_chacha@0.3.1
164         rand_core@0.6.4
165         redox_syscall@0.5.2
166         redox_users@0.4.5
167         regex-automata@0.4.7
168         regex-syntax@0.8.4
169         regex@1.10.5
170         region@3.0.2
171         reqwest@0.12.5
172         ring@0.17.8
173         rmp@0.8.14
174         rmpv@1.3.0
175         rsa@0.9.6
176         rustc-demangle@0.1.24
177         rustc-hash@1.1.0
178         rustix@0.38.34
179         rustls-native-certs@0.7.0
180         rustls-pemfile@2.1.2
181         rustls-pki-types@1.7.0
182         rustls-webpki@0.102.4
183         rustls@0.23.10
184         rustversion@1.0.17
185         ryu@1.0.18
186         schannel@0.1.23
187         scoped-tls@1.0.1
188         scopeguard@1.2.0
189         security-framework-sys@2.11.0
190         security-framework@2.11.0
191         serde@1.0.203
192         serde_derive@1.0.203
193         serde_json@1.0.118
194         serde_path_to_error@0.1.16
195         serde_repr@0.1.19
196         serde_urlencoded@0.7.1
197         sha1@0.10.6
198         sha2@0.10.8
199         signal-hook-registry@1.4.2
200         signature@2.2.0
201         slab@0.4.9
202         smallvec@1.13.2
203         smawk@0.3.2
204         smithay-client-toolkit@0.18.1
205         smithay-clipboard@0.7.1
206         socket2@0.5.7
207         spin@0.9.8
208         spki@0.7.3
209         strsim@0.11.1
210         subtle@2.6.1
211         syn@2.0.68
212         sync_wrapper@0.1.2
213         sync_wrapper@1.0.1
214         tempfile@3.10.1
215         terminal_size@0.3.0
216         textwrap@0.16.1
217         thiserror-impl@1.0.61
218         thiserror@1.0.61
219         tinyvec@1.6.1
220         tinyvec_macros@0.1.1
221         tokio-macros@2.3.0
222         tokio-rustls@0.26.0
223         tokio-stream@0.1.15
224         tokio-tungstenite@0.23.1
225         tokio@1.38.0
226         totp-lite@2.0.1
227         tower-layer@0.3.2
228         tower-service@0.3.2
229         tower@0.4.13
230         tracing-attributes@0.1.27
231         tracing-core@0.1.32
232         tracing@0.1.40
233         try-lock@0.2.5
234         tungstenite@0.23.0
235         typenum@1.17.0
236         unicode-bidi@0.3.15
237         unicode-ident@1.0.12
238         unicode-linebreak@0.1.5
239         unicode-normalization@0.1.23
240         unicode-width@0.1.13
241         untrusted@0.9.0
242         url@2.5.2
243         urlencoding@2.1.3
244         utf-8@0.7.6
245         utf8parse@0.2.2
246         uuid@1.9.1
247         version_check@0.9.4
248         want@0.3.1
249         wasi@0.11.0+wasi-snapshot-preview1
250         wasm-bindgen-backend@0.2.92
251         wasm-bindgen-futures@0.4.42
252         wasm-bindgen-macro-support@0.2.92
253         wasm-bindgen-macro@0.2.92
254         wasm-bindgen-shared@0.2.92
255         wasm-bindgen@0.2.92
256         wayland-backend@0.3.4
257         wayland-client@0.31.3
258         wayland-csd-frame@0.3.0
259         wayland-cursor@0.31.3
260         wayland-protocols-wlr@0.2.0
261         wayland-protocols@0.31.2
262         wayland-scanner@0.31.2
263         wayland-sys@0.31.2
264         web-sys@0.3.69
265         winapi-i686-pc-windows-gnu@0.4.0
266         winapi-x86_64-pc-windows-gnu@0.4.0
267         winapi@0.3.9
268         windows-sys@0.45.0
269         windows-sys@0.48.0
270         windows-sys@0.52.0
271         windows-targets@0.42.2
272         windows-targets@0.48.5
273         windows-targets@0.52.5
274         windows_aarch64_gnullvm@0.42.2
275         windows_aarch64_gnullvm@0.48.5
276         windows_aarch64_gnullvm@0.52.5
277         windows_aarch64_msvc@0.42.2
278         windows_aarch64_msvc@0.48.5
279         windows_aarch64_msvc@0.52.5
280         windows_i686_gnu@0.42.2
281         windows_i686_gnu@0.48.5
282         windows_i686_gnu@0.52.5
283         windows_i686_gnullvm@0.52.5
284         windows_i686_msvc@0.42.2
285         windows_i686_msvc@0.48.5
286         windows_i686_msvc@0.52.5
287         windows_x86_64_gnu@0.42.2
288         windows_x86_64_gnu@0.48.5
289         windows_x86_64_gnu@0.52.5
290         windows_x86_64_gnullvm@0.42.2
291         windows_x86_64_gnullvm@0.48.5
292         windows_x86_64_gnullvm@0.52.5
293         windows_x86_64_msvc@0.42.2
294         windows_x86_64_msvc@0.48.5
295         windows_x86_64_msvc@0.52.5
296         winreg@0.52.0
297         x11-clipboard@0.9.2
298         x11rb-protocol@0.13.1
299         x11rb@0.13.1
300         xcursor@0.3.5
301         xkeysym@0.2.1
302         zeroize@1.8.1
305 inherit cargo shell-completion
307 DESCRIPTION="Unofficial Bitwarden CLI"
308 HOMEPAGE="https://github.com/doy/rbw"
309 SRC_URI="
310         https://github.com/doy/rbw/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
311         ${CARGO_CRATE_URIS}
314 LICENSE="MIT"
315 # Dependent crate licenses
316 LICENSE+=" Apache-2.0 BSD Boost-1.0 ISC MIT Unicode-DFS-2016"
317 SLOT="0"
318 KEYWORDS="~amd64"
320 QA_FLAGS_IGNORED="
321         usr/bin/rbw
322         usr/bin/rbw-agent
325 src_install() {
326         cargo_src_install
328         local rbw
329         rbw="target/$(usex debug debug release)/rbw"
331         "$rbw" gen-completions bash > rbw || die
332         dobashcomp rbw
334         "$rbw" gen-completions fish > rbw.fish || die
335         dofishcomp rbw.fish
337         "$rbw" gen-completions zsh > _rbw || die
338         dozshcomp _rbw