app-editors/zed: add 0.144.3, drop 0.143.7
[gentoo-zh.git] / dev-util / elfembed / elfembed-0.3-r1.ebuild
blobc27c7bdbf84f2ee54e16816d2f2c0a0a2291d7da
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit toolchain-funcs flag-o-matic
8 DESCRIPTION="Resource Compiler for ELF binaries"
9 HOMEPAGE="http://elfembed.sourceforge.net/index.php"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 x86"
16 src_prepare(){
17         default
18         sed 's/gcc/\$\{CC\}/g' -i Makefile
21 src_compile(){
22         emake OPT="${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)"
25 src_install(){
26         dodir /usr/bin
27         install rc "${D}/usr/bin/rc"
28         install re "${D}/usr/bin/re"