app-editors/zed: add 0.144.3, drop 0.143.7
[gentoo-zh.git] / media-plugins / gimp-gap / gimp-gap-2.8.0.ebuild
blob122cd7d1586219b6211ec0bbcf3a157f6fe889fd
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools
8 MY_PV=$(ver_cut 1)-$(ver_cut 2)
9 DESCRIPTION="Gimp Animation Package"
10 SRC_URI="https://gitlab.gnome.org/Archive/gimp-gap/-/archive/gap-${MY_PV}/gimp-gap-gap-${MY_PV}.tar.bz2"
11 HOMEPAGE="http://www.gimp.org/"
13 KEYWORDS="~amd64"
14 SLOT="0"
15 LICENSE="GPL-2"
16 IUSE="mpeg mp3"
18 S="${WORKDIR}/${PN}-gap-${MY_PV}"
20 DEPEND="
21         >=media-gfx/gimp-2.8
22         mpeg? ( media-libs/xvid )
24 RDEPEND="
25         ${DEPEND}
26         app-arch/lbzip2
27         media-libs/faac
28         media-libs/faad2
29         media-libs/x264
30         mp3? ( >=media-sound/lame-3.9 )
33 src_prepare() {
34         eaclocal
35         eautoheader
36         eautomake
37         eautoconf
38         einfo "Running glib-gettextize --force"
39         glib-gettextize --force || die
40         einfo "intltoolize --force --automake"
41         intltoolize --force --automake || die
43         default
45         bsdtar -xf extern_libs/ffmpeg.tar.gz -C extern_libs || die
46         # fix building with binutil >= 2.41
47         # https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/effadce6c756247ea8bae32dc13bb3e6f464f0eb
48         patch -Np1 -i "${FILESDIR}/gimp-gap-2.8-fix-build-for-bundled-ffmpeg.patch" -d extern_libs/ffmpeg || die
49         mv -v "${S}"/configure.{ac,in} || die
50         # fix library linking order
51         sed -i 's/$FFMPEG_LIBAVUTIL_A $FFMPEG_LIBSWSCALE_A/$FFMPEG_LIBSWSCALE_A $FFMPEG_LIBAVUTIL_A/' configure.in || die
54 src_compile() {
55         # anything other than -j1 might fail
56         emake -j1
59 src_configure() {
60         export LIBS='-lm'
61         econf --with-ffmpegsrcdir="${S}"/extern_libs/ffmpeg
64 src_install() {
65         make DESTDIR="${ED}" install || die "install failed"
66         dodoc AUTHORS ChangeLog* NEWS README
67         docinto howto
68         dodoc docs/howto/txt/*.txt
69         docinto reference
70         dodoc docs/reference/txt/*.txt