app-editors/zed: add 0.144.3, drop 0.143.7
[gentoo-zh.git] / media-plugins / osdlyrics / osdlyrics-0.5.14.ebuild
blobd1f19c26a268445b59ecdb6529132000919acf48
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 PYTHON_COMPAT=( python3_{9..11} )
7 inherit python-r1 autotools optfeature xdg
9 DESCRIPTION="Standalone lyrics fetcher/displayer (windowed and OSD mode)."
10 HOMEPAGE="https://github.com/osdlyrics/osdlyrics"
12 LICENSE="GPL-3"
13 SLOT="0"
15 if [[ "${PV}" == 9999 ]]; then
16         inherit git-r3
17         EGIT_REPO_URI="https://github.com/osdlyrics/osdlyrics.git"
18 else
19         KEYWORDS="~amd64"
20         SRC_URI="https://github.com/osdlyrics/osdlyrics/archive/${PV}.tar.gz -> ${P}.tar.gz"
23 IUSE="gnome indicator"
24 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
26 RDEPEND="
27         ${PYTHON_DEPS}
28         x11-libs/libnotify
29         dev-libs/dbus-glib
30         dev-python/chardet[${PYTHON_USEDEP}]
31         dev-python/dbus-python[${PYTHON_USEDEP}]
32         dev-python/future[${PYTHON_USEDEP}]
33         dev-python/pygobject[${PYTHON_USEDEP}]
34         dev-python/pycurl[${PYTHON_USEDEP}]
35         gnome? ( dev-libs/gobject-introspection )
36         indicator? ( dev-libs/libappindicator )
37         x11-libs/gtk+:2
40 DEPEND="
41         dev-util/intltool
42         ${RDEPEND}
45 src_prepare() {
46         default
47         eautoreconf
48         python_copy_sources
51 src_configure() {
52         configuring() {
53                 local myconf=(
54                         --prefix="${EPREFIX}/usr" PYTHON="${PYTHON}"
55                         $(use_enable indicator appindicator)
56                 )
57                 econf "${myconf[@]}"
58         }
59         python_foreach_impl run_in_build_dir configuring
62 src_compile() {
63         python_foreach_impl run_in_build_dir default
66 src_install() {
67         python_foreach_impl run_in_build_dir default
70 pkg_postinst() {
71         xdg_pkg_postinst
72         if has_version media-sound/mpd; then
73                 optfeature "to interface with MPD" dev-python/python-mpd2
74         fi