1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 PYTHON_COMPAT=( python3_{9..11} )
7 inherit python-r1 autotools optfeature xdg
9 DESCRIPTION="Standalone lyrics fetcher/displayer (windowed and OSD mode)."
10 HOMEPAGE="https://github.com/osdlyrics/osdlyrics"
15 if [[ "${PV}" == 9999 ]]; then
17 EGIT_REPO_URI="https://github.com/osdlyrics/osdlyrics.git"
20 SRC_URI="https://github.com/osdlyrics/osdlyrics/archive/${PV}.tar.gz -> ${P}.tar.gz"
23 IUSE="gnome indicator"
24 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
30 dev-python/chardet[${PYTHON_USEDEP}]
31 dev-python/dbus-python[${PYTHON_USEDEP}]
32 dev-python/future[${PYTHON_USEDEP}]
33 dev-python/pygobject[${PYTHON_USEDEP}]
34 dev-python/pycurl[${PYTHON_USEDEP}]
35 gnome? ( dev-libs/gobject-introspection )
36 indicator? ( dev-libs/libappindicator )
54 --prefix="${EPREFIX}/usr" PYTHON="${PYTHON}"
55 $(use_enable indicator appindicator)
59 python_foreach_impl run_in_build_dir configuring
63 python_foreach_impl run_in_build_dir default
67 python_foreach_impl run_in_build_dir default
72 if has_version media-sound/mpd; then
73 optfeature "to interface with MPD" dev-python/python-mpd2