1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 inherit go-module systemd
7 DESCRIPTION="A DNS forwarder"
8 HOMEPAGE="https://github.com/IrineSistiana/mosdns"
10 https://github.com/IrineSistiana/mosdns/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
11 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-deps.tar.xz
14 RDEPEND="!net-dns/mosdns:4"
18 KEYWORDS="~amd64 ~arm64 ~riscv"
23 -X main.version=${PV} \
25 ego build -o ${P} -trimpath -ldflags "${ldflags}"
26 ./${P} config gen config.yaml
30 use systemd && systemd_dounit "${FILESDIR}/mosdns.service"