media-plugins/waylyrics: add 0.2.15, drop 0.2.13
[gentoo-zh.git] / dev-python / qasync / qasync-0.26.0.ebuild
blob38f5990c0082b6d9df7c890c4a0171f7c06c4b88
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 DISTUTILS_USE_PEP517=poetry
6 PYTHON_COMPAT=( python3_{9..11} )
8 inherit distutils-r1 pypi
10 DESCRIPTION="Implementation of the asyncio (PEP 3156) event-loop with Qt"
11 HOMEPAGE="https://github.com/CabbageDevelopment/qasync"
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE="qt6"
18 RDEPEND="
19 || (
20 dev-python/PyQt5[${PYTHON_USEDEP}]
21 dev-python/pyside2[${PYTHON_USEDEP}]
24 qt6? (
25 || (
26 dev-python/PyQt6[${PYTHON_USEDEP}]
27 dev-python/pyside6[${PYTHON_USEDEP}]
32 DEPEND="
33 dev-python/setuptools[${PYTHON_USEDEP}]