net-proxy/trojan-go-fork: update SRC_URI
[gentoo-zh.git] / net-proxy / trojan-go-fork / trojan-go-fork-2024.11.10.ebuild
blob588816803e28f2c206749975dc62b3640ab4c16b
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit systemd go-module
8 DESCRIPTION="A fork of trojan-go"
9 HOMEPAGE="https://github.com/Potterli20/trojan-go-fork"
10 SRC_URI="
11 https://github.com/Potterli20/trojan-go-fork/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz
12 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64"
19 DEPEND="
20 app-alternatives/v2ray-geoip
21 app-alternatives/v2ray-geosite
23 RDEPEND="${DEPEND}"
24 BDEPEND=">=dev-lang/go-1.22"
26 src_compile() {
27 ego build -tags "full"
30 src_install() {
31 dobin trojan-go-fork
32 dosym -r /usr/bin/trojan-go-fork /usr/bin/trojan-go
34 insinto /etc/trojan-go
35 doins example/*.json
37 systemd_dounit example/*.service
39 dosym -r /usr/share/v2ray/geosite.dat /usr/share/trojan-go/geosite.dat
40 dosym -r /usr/share/v2ray/geoip.dat /usr/share/trojan-go/geoip.dat