net-misc/rustdesk: update deps
[gentoo-zh.git] / app-i18n / fcitx-hangul / fcitx-hangul-5.1.0.ebuild
blob4f632d099df5b2819ec4637316d6bc9d61ca0d00
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI="7"
6 inherit cmake xdg-utils
8 if [[ "${PV}" =~ (^|\.)9999$ ]]; then
9 inherit git-r3
11 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-hangul"
14 MY_PN="fcitx5-hangul"
15 MY_P="${MY_PN}-${PV}"
16 S="${WORKDIR}/${MY_PN}-${PV}"
17 DESCRIPTION="Korean Hangul input method for Fcitx"
18 HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-hangul"
19 if [[ "${PV}" =~ (^|\.)9999$ ]]; then
20 SRC_URI=""
21 else
22 SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_P}.tar.xz"
25 LICENSE="GPL-2+"
26 SLOT="5"
27 KEYWORDS="~amd64 ~x86"
28 IUSE=""
30 BDEPEND="sys-devel/gettext
31 virtual/pkgconfig"
32 DEPEND=">=app-i18n/fcitx-5.0.2:5
33 >=app-i18n/libhangul-0.0.12
34 virtual/libiconv
35 virtual/libintl"
36 RDEPEND="${DEPEND}"
38 DOCS=(AUTHORS)
40 pkg_postinst() {
41 xdg_icon_cache_update
44 pkg_postrm() {
45 xdg_icon_cache_update