net-misc/rustdesk: update deps
[gentoo-zh.git] / app-i18n / fcitx-rime / fcitx-rime-5.1.1.ebuild
blob9aba61adead5523fe680700ddb4b0247c20a7fa6
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit xdg cmake
8 DESCRIPTION="Rime Support for Fcitx5"
9 HOMEPAGE="https://github.com/fcitx/fcitx5-rime"
11 if [[ "${PV}" == 9999 ]]; then
12 inherit git-r3
13 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-rime.git"
14 else
15 MY_PN="fcitx5-rime"
16 S="${WORKDIR}/${MY_PN}-${PV}"
17 SRC_URI="https://github.com/fcitx/fcitx5-rime/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
18 KEYWORDS="~amd64 ~arm64 ~x86"
21 LICENSE="GPL-2"
22 SLOT="5"
23 IUSE=""
25 RDEPEND="
26 >=app-i18n/fcitx-5.1.0:5
27 >=app-i18n/librime-1.0
28 >=app-i18n/rime-data-0.3.0
29 app-i18n/rime-prelude
30 x11-libs/libnotify"
32 DEPEND="${RDEPEND}"