media-plugins/waylyrics: add 0.3.12, drop 0.3.11
[gentoo-zh.git] / games-util / winegame-client-bin / winegame-client-bin-0.5.12.2.ebuild
blob9967eae9323ee686cb04afde9f1382f2ec4692da
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 PYTHON_COMPAT=( python3_{10..11} )
7 PYTHON_REQ_USE="sqlite,threads(+)"
9 inherit unpacker xdg python-r1
11 DESCRIPTION="An open source gaming platform for GNU/Linux"
12 HOMEPAGE="https://winegame.net/"
13 SRC_URI="https://file.winegame.net/packages/debian/${PV}/net.winegame.client_${PV}_amd64.deb"
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64"
18 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20 RESTRICT="mirror"
22 DEPEND="app-arch/cabextract"
24 RDEPEND="
25         ${PYTHON_DEPS}
26         app-arch/unzip
27         app-arch/p7zip
28         net-misc/curl
29         net-misc/aria2
30         $(python_gen_cond_dep '
31                 dev-python/dbus-python[${PYTHON_USEDEP}]
32                 dev-python/pillow[${PYTHON_USEDEP}]
33                 dev-python/pygobject:3[${PYTHON_USEDEP}]
34                 dev-python/evdev[${PYTHON_USEDEP}]
35                 dev-python/python-magic[${PYTHON_USEDEP}]
36                 dev-python/pyyaml[${PYTHON_USEDEP}]
37                 dev-python/requests[${PYTHON_USEDEP}]
38                 dev-python/pydbus[${PYTHON_USEDEP}]
39                 dev-python/distro[${PYTHON_USEDEP}]
40         ')
41         gnome-base/gnome-desktop:3[introspection]
42         gnome-extra/zenity
43         net-libs/webkit-gtk:4[introspection]
44         media-sound/fluid-soundfont
45         x11-apps/mesa-progs
46         x11-apps/xrandr
47         x11-apps/xgamma
48         x11-libs/gtk+:3[introspection]
49         virtual/wine
52 S=${WORKDIR}
54 src_install() {
55         insinto /
56         doins -r usr opt
58         fperms -R 755 /opt/apps/net.winegame.client/files/bin
59         fperms -R 755 /opt/apps/net.winegame.client/files/share/lutris/bin