net-im/wemeet: depend media-libs/tiff-compat:4
[gentoo-zh.git] / dev-vcs / lazygit / lazygit-0.35.ebuild
blob58be2c3276ef77d32590c8b9e8fd99a1a8091c01
1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit go-module
8 DESCRIPTION="lazygit, a simple terminal UI for git commands"
9 HOMEPAGE="https://github.com/jesseduffield/lazygit"
10 SRC_URI="https://github.com/jesseduffield/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64"
16 CONFLICTS="!dev-vcs/lazygit-bin"
17 RDEPEND="
18 ${CONFLICTS}
19 dev-vcs/git
22 DOCS=( {CODE-OF-CONDUCT,CONTRIBUTING,README}.md docs )
24 src_compile(){
25 ego build -o bin/lazygit
28 src_install(){
29 dobin bin/lazygit
31 default