net-proxy/sing-box: add 1.10.7, drop 1.10.6
[gentoo-zh.git] / app-admin / chezmoi-bin / chezmoi-bin-2.58.0.ebuild
blobc47363b8f841428ab258360c67d7d0b5f03a88d1
1 # Copyright 1999-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit unpacker
8 DESCRIPTION="Manage your dotfiles across multiple diverse machines, securely."
9 HOMEPAGE="https://www.chezmoi.io https://github.com/twpayne/chezmoi"
11 SRC_URI="
12 amd64? ( https://github.com/twpayne/chezmoi/releases/download/v${PV}/chezmoi_${PV}_linux_amd64.deb )
13 x86? ( https://github.com/twpayne/chezmoi/releases/download/v${PV}/chezmoi_${PV}_linux_i386.deb )
14 arm64? ( https://github.com/twpayne/chezmoi/releases/download/v${PV}/chezmoi_${PV}_linux_arm64.deb )
15 arm? ( https://github.com/twpayne/chezmoi/releases/download/v${PV}/chezmoi_${PV}_linux_armel.deb )
18 S="${WORKDIR}"
20 LICENSE="MIT"
21 SLOT="0"
22 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
24 RDEPEND="dev-vcs/git"
25 RDEPEND+=" !app-admin/chezmoi"
27 src_install() {
28 default
30 dobin usr/bin/chezmoi
32 insinto /usr/share/bash-completion/completions
33 doins usr/share/bash-completion/completions/chezmoi
35 insinto /usr/share/zsh/vendor-completions
36 doins usr/share/zsh/vendor-completions/_chezmoi