1 # Copyright 2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit desktop unpacker xdg
8 DESCRIPTION
="A cross-platform, complete password management solution."
9 HOMEPAGE
="https://www.enpass.io"
10 SRC_URI
="https://apt.enpass.io/pool/main/e/${PN}/${PN}_${PV}_amd64.deb"
18 RESTRICT
="bindist mirror strip"
22 # objdump -p ./Enpass | grep NEEDED | awk '{print $2}' | xargs equery b | sort | uniq
24 DEPEND
="elibc_glibc? ( sys-libs/glibc:2.2 )"
40 x11-libs/libXScrnSaver
44 x11-libs/xcb-util-image
45 x11-libs/xcb-util-keysyms
46 x11-libs/xcb-util-renderutil
49 QA_PREBUILT
="opt/enpass/*"
53 gzip -d "${S}"/usr
/share
/doc
/enpass
/changelog.gz || die
57 domenu
"${S}"/usr
/share
/applications
/enpass.desktop
58 dodoc
"${S}"/usr
/share
/doc
/enpass
/changelog
61 doins
-r "${S}"/opt
/enpass
/.
62 fperms
+x
/opt
/enpass
/{Enpass
,importer_enpass
,wifisyncserver_bin
}
64 insinto
/usr
/share
/mime
/packages
65 doins
"${S}"/usr
/share
/mime
/packages
/application-enpass.xml
68 for size
in 16 22 24 32 48; do
69 doicon
-c status
-s ${size} "${S}"/usr/share/icons/hicolor/${size}x${size}/status
/enpass-status.png
70 doicon
-c status
-s ${size} "${S}"/usr/share/icons/hicolor/${size}x${size}/status
/enpass-status-dark.png
73 for size
in 16 24 32 48 64 96 128 256; do
74 doicon
-s ${size} "${S}"/usr/share/icons/hicolor/${size}x${size}/apps
/enpass.png