net-proxy/sing-box: add 1.10.7, drop 1.10.6
[gentoo-zh.git] / app-backup / restic-rest-server / restic-rest-server-0.13.0.ebuild
blobc3f4fb6049e0806f30ebaf8c76823eb97a9a5cea
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit go-module
8 MY_PN="rest-server"
9 DESCRIPTION="A high performance HTTP server that implements restic's REST backend API"
10 HOMEPAGE="https://github.com/restic/rest-server"
11 SRC_URI="
12 https://github.com/restic/rest-server/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
13 https://github.com/Linerre/gentoo-deps/releases/download/${P}/${P}-deps.tar.xz
16 S="${WORKDIR}/${MY_PN}-${PV}"
17 LICENSE="BSD-2"
18 SLOT="0"
19 KEYWORDS="~amd64"
20 QA_PRESTRIPPED="/usr/bin/${PN}"
22 src_compile() {
23 ego run build.go
26 src_install() {
27 newbin ${MY_PN} ${PN}