app-office/anytype-bin: add 0.43.7, drop 0.43.6
[gentoo-zh.git] / app-crypt / archlinux-keyring / archlinux-keyring-20240208-r1.ebuild
blob540654a9bd5044364d282839f90c839396a3708c
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DESCRIPTION="GnuPG keyring of Archlinux developer keys"
7 HOMEPAGE="https://gitlab.archlinux.org/archlinux/archlinux-keyring"
8 #SRC_URI="https://sources.archlinux.org/other/${PN}/${P}.tar.gz"
9 SRC_URI="https://gitlab.archlinux.org/archlinux/${PN}/-/archive/${PV}/${P}.tar.bz2"
11 LICENSE="GPL-2" # "GPL" for the Arch linux package
12 SLOT="0"
14 KEYWORDS="~amd64"
15 PATCHES="${FILESDIR}/01_adapt_to_sequoia_sq_0_34.patch"
17 BDEPEND=">=app-crypt/sequoia-sq-0.33.0"
19 src_compile(){
20 emake build
23 src_install(){
24 emake PREFIX='/usr' DESTDIR="${D}" install
27 pkg_postinst() {
28 einfo ""
29 einfo "This package only installs the keyring files while sys-apps/pacman"
30 einfo "initializes these keyrings to actually use it. This is a different"
31 einfo "behaviour from Archlinux, but is necessary to avoid circular deps."
32 einfo ""