net-misc/hoppscotch-bin: bump version to 24.12.1.0 (#6084)
[gentoo-zh.git] / app-dicts / fcitx-pinyin-moegirl-bin / fcitx-pinyin-moegirl-bin-20250111.ebuild
blob2d0064594f06449bd044bd25d807986c92e40bf9
1 # Copyright 1999-2025 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DESCRIPTION="Fcitx 5 Pinyin Dictionary from zh.moegirl.org.cn"
7 HOMEPAGE="https://github.com/outloudvi/mw2fcitx"
8 SRC_URI="
9 fcitx? ( https://github.com/outloudvi/mw2fcitx/releases/download/${PV}/moegirl.dict -> ${P}.dict )
10 rime? ( https://github.com/outloudvi/mw2fcitx/releases/download/${PV}/moegirl.dict.yaml -> ${P}.dict.yaml )
13 S="${DISTDIR}"
15 LICENSE="Unlicense CC-BY-NC-SA-3.0"
16 SLOT="5"
17 KEYWORDS="~amd64 ~mips ~x86"
18 IUSE="+fcitx rime"
19 REQUIRED_USE="|| ( fcitx rime )"
21 RDEPEND="
22 fcitx? ( app-i18n/fcitx:5 )
23 rime? ( || ( app-i18n/ibus-rime app-i18n/fcitx-rime ) )
24 !app-dicts/fcitx-pinyin-moegirl
27 src_install() {
28 if use fcitx; then
29 DICT_PATH="/usr/share/fcitx5/pinyin/dictionaries"
30 insinto "${DICT_PATH}"
31 newins "${P}.dict" moegirl.dict
32 fperms 0644 "${DICT_PATH}/moegirl.dict"
35 if use rime; then
36 DICT_PATH="/usr/share/rime-data"
37 insinto "${DICT_PATH}"
38 newins "${P}.dict.yaml" moegirl.dict.yaml
39 fperms 0644 "${DICT_PATH}/moegirl.dict.yaml"