x11-terms/ghostty: add missing depend dev-libs/oniguruma
[gentoo-zh.git] / app-editors / typora / typora-1.9.3.ebuild
blob165f410d591f12c94e01e6522676ccc9a9304ec0
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit unpacker xdg
8 DESCRIPTION="A truely minimal markdown editor."
9 HOMEPAGE="https://typora.io"
10 SRC_URI="https://download.typora.io/linux/typora_${PV}_amd64.deb"
11 S="${WORKDIR}"
13 LICENSE="typora"
14 SLOT="0"
15 KEYWORDS="~amd64"
17 RESTRICT="mirror splitdebug"
19 RDEPEND="
20 x11-libs/libXScrnSaver
21 net-print/cups"
23 QA_PREBUILT="*"
25 src_unpack() {
26 unpack_deb typora_${PV}_amd64.deb
29 src_install() {
30 mv "${S}/usr" "${D}" || die
32 pushd "${D}/usr/share/doc" > /dev/null || die
33 mv ${PN} ${P} || die
34 popd > /dev/null || die