1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
9 MY_COMMIT="1b837fd8bc99ea0cfd74e7d85bb4357542f5e1f2"
11 DESCRIPTION="Linux kernel module for compatibility with LoongArch's old-world ABI"
12 HOMEPAGE="https://github.com/AOSC-Dev/la_ow_syscall"
16 EGIT_REPO_URI="https://github.com/AOSC-Dev/la_ow_syscall"
20 MY_P="la_ow_syscall-${MY_COMMIT}"
21 SRC_URI="https://codeload.github.com/AOSC-Dev/la_ow_syscall/zip/${MY_COMMIT} -> ${MY_P}.zip"
22 S="${WORKDIR}/${MY_P}"
29 RESTRICT="mirror test"
31 BDEPEND="app-arch/unzip"
39 # otherwise the build script uses `uname -r` that will break if the
40 # target kernel version differs from the running one
41 export KVER="${KV_FULL}"
46 linux-mod-r1_src_compile
50 linux-mod-r1_src_install
52 insinto /usr/lib/modules-load.d
53 doins "${FILESDIR}/la-ow-syscall.conf"
57 linux-mod-r1_pkg_postinst
59 elog "Be sure to load the kernel module before running any old-world program:"
61 elog "# modprobe la_ow_syscall"
63 elog "A config file has been installed under /usr/lib/modules-load.d for"
64 elog "automatic loading of the compatibility patch on system start-up."