app-shells/zfe: add nvchecker
[gentoo-zh.git] / app-i18n / fcitx-m17n / fcitx-m17n-9999.ebuild
blobb6c331f7006f8a82c56e3094cf97ad6b615718a1
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit cmake git-r3
7 DESCRIPTION="m17n-provided input methods for Fcitx5"
8 HOMEPAGE="https://github.com/fcitx/fcitx5-m17n"
9 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-m17n.git"
11 LICENSE="LGPL-2.1+"
12 SLOT="5"
13 IUSE="coverage test"
14 RESTRICT="!test? ( test )"
16 # m17n-gui>=1.6.3
17 RDEPEND="
18 >=app-i18n/fcitx-5.1.5:5
19 >=dev-libs/m17n-lib-1.6.3[X]
20 dev-db/m17n-db
21 dev-libs/libfmt
23 DEPEND="${RDEPEND}"
24 BDEPEND="
25 test? (
26 coverage? (
27 dev-util/lcov
32 src_configure() {
33 local mycmakeargs=(
34 -DENABLE_TEST=$(usex test)
35 -DENABLE_COVERAGE=$(usex coverage)
37 cmake_src_configure