app-shells/zfe: add nvchecker
[gentoo-zh.git] / app-i18n / fcitx-skk / fcitx-skk-5.1.5.ebuild
blobd915c3d4e7212d4e249241430b1679d111af2462
1 # Copyright 2021-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MY_PN="fcitx5-skk"
8 inherit cmake unpacker xdg
10 DESCRIPTION="Japanese SKK input engine for Fcitx5"
11 HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-skk"
12 SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.zst"
13 S="${WORKDIR}/${MY_PN}-${PV}"
15 LICENSE="GPL-3+"
16 SLOT="5"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+qt5 qt6"
19 REQUIRED_USE="^^ ( qt5 qt6 )"
21 RDEPEND="
22 >=app-i18n/fcitx-5.1.6:5
23 app-i18n/fcitx-qt[qt5?,qt6?,-onlyplugin]
24 app-i18n/libskk
25 app-i18n/skk-jisyo
26 qt5? (
27 dev-qt/qtcore:5
28 dev-qt/qtgui:5=
29 dev-qt/qtwidgets:5
31 qt6? (
32 dev-qt/qtbase:6[dbus,gui,widgets]
35 DEPEND="${RDEPEND}"
36 BDEPEND="
37 kde-frameworks/extra-cmake-modules:0
38 virtual/pkgconfig
41 src_configure() {
42 local mycmakeargs=( )
43 if use qt5 || use qt6; then
44 mycmakeargs+=(
45 -DENABLE_QT=ON
46 -DUSE_QT6=$(usex qt6)
49 cmake_src_configure