net-print/kyodialog: update SRC_URI
[gentoo-zh.git] / app-i18n / fcitx-skk / fcitx-skk-9999.ebuild
blob99f93d40a274acd1e591277e90ca518581f75463
1 # Copyright 2021-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake git-r3 xdg
8 DESCRIPTION="Japanese SKK input engine for Fcitx5"
9 HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-skk"
10 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-skk"
12 LICENSE="GPL-3+"
13 SLOT="5"
14 IUSE="+qt5 qt6"
15 REQUIRED_USE="^^ ( qt5 qt6 )"
17 RDEPEND="
18 >=app-i18n/fcitx-5.1.6:5
19 app-i18n/fcitx-qt[qt5?,qt6?,-onlyplugin]
20 app-i18n/libskk
21 app-i18n/skk-jisyo
22 qt5? (
23 dev-qt/qtcore:5
24 dev-qt/qtgui:5=
25 dev-qt/qtwidgets:5
27 qt6? (
28 dev-qt/qtbase:6[dbus,gui,widgets]
31 DEPEND="${RDEPEND}"
32 BDEPEND="
33 kde-frameworks/extra-cmake-modules:0
34 virtual/pkgconfig
37 src_configure() {
38 local mycmakeargs=( )
39 if use qt5 || use qt6; then
40 mycmakeargs+=(
41 -DENABLE_QT=ON
42 -DUSE_QT6=$(usex qt6)
45 cmake_src_configure