1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 MY_PN
="${PN##zsh-theme-}"
8 DESCRIPTION
="Theme for Zsh that emphasizes speed, flexibility and out-of-the-box experience"
9 HOMEPAGE
="https://github.com/romkatv/powerlevel10k"
10 SRC_URI
="https://github.com/romkatv/powerlevel10k/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14 KEYWORDS
="~amd64 ~x86"
16 DEPEND
="app-shells/zsh
17 app-shells/gitstatus[zsh-completion]"
20 S
="${WORKDIR}/${MY_PN}-${PV}"
23 sed -i Makefile
-e '/gitstatus/d' || die
33 dodoc
{README
,font
}.md
35 insinto
"/usr/share/zsh/site-functions/${MY_PN}"
40 doins powerlevel
*.zsh-theme
{,.zwc
}
42 dosym ..
/..
/..
/gitstatus \
43 "/usr/share/zsh/site-functions/${MY_PN}/gitstatus"
47 elog
"To use this theme, source /usr/share/zsh/site-functions/powerlevel10k/powerlevel10k.zsh-theme in your ~/.zshrc"
48 elog
"The full choice of style options is available only when using Nerd Fonts. For example: media-fonts/nerd-fonts"