app-shells/zfe: add nvchecker
[gentoo-zh.git] / dev-java / google-java-format / google-java-format-1.25.2.ebuild
blobf4c88fe8d55ca1c4459d9df0b08375b80d8634f6
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DESCRIPTION="Reformats Java source code to comply with Google Java Style."
7 HOMEPAGE="https://github.com/google/google-java-format"
8 SRC_URI="https://github.com/google/google-java-format/releases/download/v${PV}/${P}-all-deps.jar"
9 S="${WORKDIR}"
11 LICENSE="Apache-2.0"
12 SLOT="0"
13 KEYWORDS="~amd64"
15 RDEPEND="virtual/jdk:17"
16 DEPEND="${RDEPEND}"
18 src_install() {
19 insinto "/usr/share/${PN}"
20 newins "${DISTDIR}/${P}-all-deps.jar" "google-java-format-all-deps.jar"
22 dobin "${FILESDIR}/${PN}"