net-proxy/sing-box: add 1.10.7, drop 1.10.6
[gentoo-zh.git] / dev-libs / libthai / libthai-0.1.29.ebuild
blob644a4d7ff8e42a4c17324e62bd70f9ddc07e262b
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools
8 DESCRIPTION="A a set of Thai language support routines"
9 HOMEPAGE="https://github.com/tlwg/libthai"
11 if [[ ${PV} == "9999" ]] ; then
12 inherit git-r3
13 EGIT_REPO_URI="https://github.com/tlwg/${PN}.git"
14 else
15 SRC_URI="https://github.com/tlwg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16 KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
19 LICENSE="LGPL-2.1"
20 SLOT="0"
22 RDEPEND="dev-libs/libdatrie"
23 DEPEND="${RDEPEND}"
24 BDEPEND="dev-vcs/git"
26 src_prepare() {
27 default
28 # Fixed version if in non git project
29 echo ${PV} > VERSION
30 # From upstreams autogen.sh, to make it utilize the autotools eclass
31 # Fix html doc path
32 sed -i -e "s|share/doc/libthai/html|share/doc/libthai-${PV}/html|g" configure.ac || die
33 # use eautoreconf from autotools.eclass instead of autogen.sh
34 eautoreconf