app-text/cajviewer: disable nvchecker
[gentoo-zh.git] / dev-python / archspec / archspec-0.2.5.ebuild
blob331213251574b299e3882661bbb5033afb13d918
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DISTUTILS_USE_PEP517=poetry
7 PYTHON_COMPAT=( python3_{9..12} )
9 inherit distutils-r1
11 DESCRIPTION="A library for detecting, labeling, and reasoning about microarchitectures"
12 HOMEPAGE="https://github.com/archspec/archspec"
14 CPUID="5b381ed2af05ad9ead46a136b43c2f7021bd44bb"
16 SRC_URI="
17 https://github.com/archspec/archspec/archive/v${PV}.tar.gz -> ${P}.tar.gz
18 https://github.com/archspec/archspec-json/archive/v${PV}.tar.gz -> ${P}-json.tar.gz
19 https://github.com/archspec/cpuid/archive/${CPUID}.tar.gz -> ${P}-cpuid.tar.gz"
21 LICENSE="Apache-2.0 MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
25 distutils_enable_tests pytest
27 src_unpack() {
28 default
29 mv -u "${PN}-json-${PV}/cpu/" "${S}/${PN}/json" || die
30 rm -r "${S}/${PN}/vendor/cpuid" || die
31 mv -u "cpuid-${CPUID}" "${S}/${PN}/vendor/cpuid" || die