1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 DISTUTILS_USE_PEP517
=setuptools
6 PYTHON_COMPAT
=( python3_
{9.
.13} pypy3
)
9 DESCRIPTION
="Create and extract conda packages of various formats"
10 HOMEPAGE
="https://github.com/conda/conda-package-handling"
11 SRC_URI
="https://github.com/conda/conda-package-handling/archive/${PV}.tar.gz -> ${P}.tar.gz"
18 dev-python/cython[${PYTHON_USEDEP}]
19 dev-python/tqdm[${PYTHON_USEDEP}]
20 dev-python/six[${PYTHON_USEDEP}]"
24 distutils_enable_tests pytest
26 python_prepare_all
() {
27 sed -i 's/archive_and_deps/archive/' setup.py || die
28 distutils-r1_python_prepare_all