www-client/thorium-browser-bin: new package, add 128.0.6613.189
[gentoo-zh.git] / dev-python / conda-package-streaming / conda-package-streaming-0.11.0.ebuild
blob5b32c2628f87652446fa4bccd77b9c4190ba94d6
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 DISTUTILS_USE_PEP517=flit
6 PYTHON_COMPAT=( python3_{9..13} pypy3 )
7 inherit distutils-r1
9 DESCRIPTION="An efficient library to read from new and old conda packages"
10 HOMEPAGE="https://github.com/conda/conda-package-streaming"
11 SRC_URI="https://github.com/conda/conda-package-streaming/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 ~x86"
17 DEPEND="
18 dev-python/requests[${PYTHON_USEDEP}]
19 dev-python/zstandard[${PYTHON_USEDEP}]"
21 RDEPEND="${DEPEND}"
23 distutils_enable_tests pytest