app-shells/zfe: add nvchecker
[gentoo-zh.git] / dev-python / janus / janus-2.0.0.ebuild
blob48955763b0f54758bea1ae75c287f5ee5a3ab2ff
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
5 DISTUTILS_USE_PEP517=setuptools
6 PYTHON_COMPAT=( python3_{9..13} pypy3 )
8 inherit distutils-r1 pypi
10 DESCRIPTION="Implementation of the asyncio (PEP 3156) event-loop with Qt"
11 HOMEPAGE="https://github.com/aio-libs/janus"
12 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
19 DEPEND="
20 dev-python/setuptools[${PYTHON_USEDEP}]
21 test? (
22 dev-python/pytest[${PYTHON_USEDEP}]
26 python_test() {
27 py.test -v || die "Tests fail with ${EPYTHON}"
30 python_install_all() {
31 distutils-r1_python_install_all