app-shells/zfe: add nvchecker
[gentoo-zh.git] / dev-python / mw2fcitx / mw2fcitx-0.16.0.ebuild
blobf3f47d03519f726987bfc8809bebb057d5a66d97
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DISTUTILS_USE_PEP517=poetry
7 DISTUTILS_SINGLE_IMPL=1
8 PYTHON_COMPAT=( python3_{10..13} )
10 inherit distutils-r1 pypi
12 DESCRIPTION="Build fcitx5 libraries from MediaWiki sites"
13 HOMEPAGE="
14 https://github.com/outloudvi/mw2fcitx
15 https://pypi.org/project/mw2fcitx
17 DICTV="20240809"
18 SRC_URI+="
19 test? ( https://github.com/outloudvi/mw2fcitx/releases/download/${DICTV}/titles.txt -> titles-${DICTV}.txt )
22 LICENSE="Unlicense test? ( CC-BY-NC-SA-3.0 )"
23 SLOT="0"
24 KEYWORDS="~amd64"
26 RDEPEND="
27 >=app-i18n/opencc-1.1.7[python(-),${PYTHON_SINGLE_USEDEP}]
28 $(python_gen_cond_dep '
29 >=dev-python/pypinyin-0.52.0[${PYTHON_USEDEP}]
30 >=dev-python/urllib3-2.2.2[${PYTHON_USEDEP}]
34 PATCHES=( "${FILESDIR}/${P}-test-no-network.patch" )
36 distutils_enable_tests pytest
38 src_unpack() {
39 default
40 use test && (cp "${DISTDIR}/titles-${DICTV}.txt" "${S}/titles.txt" || die)