www-apps/follow-bin: add 0.2.3_beta0, drop 0.2.2_beta0
[gentoo-zh.git] / dev-python / nvchecker / nvchecker-2.15.1.ebuild
blob909c34b89d9778f06a9c9995467db19e033f1a58
1 # Copyright 2022-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DISTUTILS_USE_PEP517=setuptools
7 PYTHON_COMPAT=( python3_{10..12} )
8 inherit distutils-r1
10 DESCRIPTION="nvchecker is for checking if a new version of some software has been released"
11 HOMEPAGE="https://pypi.org/project/nvchecker/"
12 SRC_URI="https://github.com/lilydjwg/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="ini notify"
18 PROPERTIES="test_network"
19 RESTRICT="test"
21 BDEPEND="
22 test? (
23 dev-python/flaky[$PYTHON_USEDEP]
24 dev-python/pytest-asyncio[$PYTHON_USEDEP]
25 dev-python/pytest-httpbin[$PYTHON_USEDEP]
28 RDEPEND="
29 dev-python/appdirs[$PYTHON_USEDEP]
30 dev-python/structlog[$PYTHON_USEDEP]
31 dev-python/tomli[$PYTHON_USEDEP]
32 >=dev-python/tornado-6[${PYTHON_USEDEP}]
33 ini? (
34 dev-python/iniconfig[$PYTHON_USEDEP]
36 notify? (
37 dev-python/pygobject[$PYTHON_USEDEP]
38 virtual/notification-daemon
42 distutils_enable_tests pytest
44 python_install_all() {
45 distutils-r1_python_install_all
47 if ! use ini; then
48 rm "${ED}"/usr/bin/nvchecker-ini2toml || die
51 if ! use notify; then
52 rm "${ED}"/usr/bin/nvchecker-notify || die