1 # Copyright 2022-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 DISTUTILS_USE_PEP517
=setuptools
7 PYTHON_COMPAT
=( python3_
{10.
.12} )
10 DESCRIPTION
="nvchecker is for checking if a new version of some software has been released"
11 HOMEPAGE
="https://pypi.org/project/nvchecker/"
12 SRC_URI
="https://github.com/lilydjwg/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
18 PROPERTIES
="test_network"
23 dev-python/flaky[$PYTHON_USEDEP]
24 dev-python/pytest-asyncio[$PYTHON_USEDEP]
25 dev-python/pytest-httpbin[$PYTHON_USEDEP]
29 dev-python/appdirs[$PYTHON_USEDEP]
30 dev-python/structlog[$PYTHON_USEDEP]
31 dev-python/tomli[$PYTHON_USEDEP]
32 >=dev-python/tornado-6[${PYTHON_USEDEP}]
34 dev-python/iniconfig[$PYTHON_USEDEP]
37 dev-python/pygobject[$PYTHON_USEDEP]
38 virtual/notification-daemon
42 distutils_enable_tests pytest
44 python_install_all
() {
45 distutils-r1_python_install_all
48 rm "${ED}"/usr
/bin
/nvchecker-ini2toml || die
52 rm "${ED}"/usr
/bin
/nvchecker-notify || die