app-shells/zfe: add nvchecker
[gentoo-zh.git] / dev-python / pypinyin / pypinyin-0.53.0.ebuild
blob28190f8ba50967dc0eddacea64ccbc56ef4299e8
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DISTUTILS_USE_PEP517=setuptools
7 PYTHON_COMPAT=( python3_{10..13} pypy3 )
9 inherit distutils-r1
11 DESCRIPTION="Tool for converting Chinese characters to pinyin"
12 HOMEPAGE="
13 https://github.com/mozillazg/python-pinyin
14 https://pypi.org/project/pypinyin
16 SRC_URI="https://github.com/mozillazg/python-pinyin/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
18 S="${WORKDIR}/python-pinyin-${PV}"
20 LICENSE="MIT"
21 SLOT="0"
22 KEYWORDS="~amd64"
24 distutils_enable_tests pytest
26 src_prepare() {
27 distutils-r1_src_prepare
28 sed -i -e '/--cov/d' pytest.ini || die
31 python_test() {
32 epytest -s