x11-terms/ghostty: add missing depend dev-libs/oniguruma
[gentoo-zh.git] / dev-vcs / sourcegit-bin / sourcegit-bin-8.44.ebuild
blob85e0be83a46c81a940a478f4a334d9bcb6eff7dc
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit desktop unpacker xdg
8 DESCRIPTION="Opensource Git GUI client."
9 HOMEPAGE="https://github.com/sourcegit-scm/sourcegit"
10 SRC_URI="https://github.com/sourcegit-scm/sourcegit/releases/download/v${PV}/sourcegit_${PV}-1_amd64.deb"
12 S="${WORKDIR}"
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 RESTRICT="strip"
18 DEPEND="
19 dev-vcs/git
22 RDEPEND="${DEPEND}"
23 src_install(){
24 insinto /opt/sourcegit
25 doins -r "${S}"/opt/sourcegit/*
26 fperms 755 /opt/sourcegit/sourcegit
27 domenu "${FILESDIR}"/sourcegit.desktop
28 doicon -s 256 "${S}"/usr/share/icons/sourcegit.png