x11-terms/ghostty: add missing depend dev-libs/oniguruma
[gentoo-zh.git] / games-action / vintagestory / vintagestory-1.19.8.ebuild
blob5e57aa967fa2aa7e4d082a29f28065c2e05fd8f7
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 DOTNET_PKG_COMPAT=7.0
6 inherit desktop dotnet-pkg-base xdg
8 DESCRIPTION="Uncompromising wilderness survival sandbox game (requires paid account)"
9 HOMEPAGE="https://www.vintagestory.at/"
11 MY_PV="${PV/_rc/-rc.}"
12 _CHANNEL="stable"
13 SRC_URI="https://cdn.vintagestory.at/gamefiles/${_CHANNEL}/vs_client_linux-x64_${MY_PV}.tar.gz"
14 S="${WORKDIR}/${PN}"
16 LICENSE="all-rights-reserved"
17 SLOT="0"
18 KEYWORDS="-* ~amd64"
20 DEPEND="
21 virtual/dotnet-sdk:${DOTNET_PKG_COMPAT}
23 RDEPEND="
24 ${DEPEND}
25 media-libs/openal
26 virtual/opengl
28 BDEPEND="
29 virtual/dotnet-sdk:${DOTNET_PKG_COMPAT}
31 # Do NOT Distribute!
32 RESTRICT="bindist mirror strip"
34 QA_PREBUILT="*"
35 QA_PRESTRIPPED="*"
37 DOTNET_PKG_OUTPUT="${S}"
38 INST_DIR="/opt/${PN}"
40 src_prepare() {
41 rm *.desktop || die
43 rm "${S}/install.sh" || die
44 rm "${S}/server.sh" || die
45 rm "${S}/run.sh" || die
47 einfo "Create symbolic links for any assets (excluding fonts) containing non-lowercase letters"
48 find "${S}"/assets/ -not -path "*/fonts/*" -regex ".*/.*[A-Z].*" | while read -r file; do
49 local filename="$(basename -- "$file")"
50 ln -sf "$filename" "${file%/*}"/"${filename,,}"
51 done
53 default
56 src_compile() {
60 src_install() {
61 newicon assets/gameicon.xpm Vintagestory.xpm
62 domenu "${FILESDIR}/Vintagestory.desktop"
63 domenu "${FILESDIR}/Vintagestory_url_connect.desktop"
64 domenu "${FILESDIR}/Vintagestory_url_mod.desktop"
66 insinto "/usr/share/fonts/${PN}"
67 doins assets/game/fonts/*.ttf
69 dotnet-pkg-base_install "${INST_DIR}"
70 dotnet-pkg-base_append-launchervar "mesa_glthread=true"
71 dotnet-pkg-base_dolauncher "${INST_DIR}/Vintagestory"