1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit desktop dotnet-pkg-base xdg
8 DESCRIPTION
="Uncompromising wilderness survival sandbox game (requires paid account)"
9 HOMEPAGE
="https://www.vintagestory.at/"
11 MY_PV
="${PV/_rc/-rc.}"
13 SRC_URI
="https://cdn.vintagestory.at/gamefiles/${_CHANNEL}/vs_client_linux-x64_${MY_PV}.tar.gz"
16 LICENSE
="all-rights-reserved"
21 virtual/dotnet-sdk:${DOTNET_PKG_COMPAT}
29 virtual/dotnet-sdk:${DOTNET_PKG_COMPAT}
32 RESTRICT
="bindist mirror strip"
37 DOTNET_PKG_OUTPUT
="${S}"
43 rm "${S}/install.sh" || die
44 rm "${S}/server.sh" || die
45 rm "${S}/run.sh" || die
47 einfo
"Create symbolic links for any assets (excluding fonts) containing non-lowercase letters"
48 find "${S}"/assets
/ -not -path "*/fonts/*" -regex ".*/.*[A-Z].*" |
while read -r file; do
49 local filename
="$(basename -- "$file")"
50 ln -sf "$filename" "${file%/*}"/"${filename,,}"
61 newicon assets
/gameicon.xpm Vintagestory.xpm
62 domenu
"${FILESDIR}/Vintagestory.desktop"
63 domenu
"${FILESDIR}/Vintagestory_url_connect.desktop"
64 domenu
"${FILESDIR}/Vintagestory_url_mod.desktop"
66 insinto
"/usr/share/fonts/${PN}"
67 doins assets
/game
/fonts
/*.ttf
69 dotnet-pkg-base_install
"${INST_DIR}"
70 dotnet-pkg-base_append-launchervar
"mesa_glthread=true"
71 dotnet-pkg-base_dolauncher
"${INST_DIR}/Vintagestory"