www-apps/follow-bin: add 0.2.3_beta0, drop 0.2.2_beta0
[gentoo-zh.git] / games-arcade / osu-lazer / osu-lazer-2024.1115.3.ebuild
blob780b4ecb3b172717a3305d33036c0220e68e41b4
1 # Copyright 2023-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DOTNET_PKG_COMPAT=8.0
7 NUGETS="
8 automapper@12.0.1
9 automapper@13.0.1
10 diffplex@1.7.2
11 discordrichpresence@1.2.1.24
12 ffmpeg.autogen@4.3.0.1
13 fody@6.8.0
14 hidsharpcore@1.2.1.1
15 htmlagilitypack@1.11.59
16 htmlagilitypack@1.11.70
17 humanizer.core.af@2.14.1
18 humanizer.core.ar@2.14.1
19 humanizer.core.az@2.14.1
20 humanizer.core.bg@2.14.1
21 humanizer.core.bn-bd@2.14.1
22 humanizer.core.cs@2.14.1
23 humanizer.core.da@2.14.1
24 humanizer.core.de@2.14.1
25 humanizer.core.el@2.14.1
26 humanizer.core.es@2.14.1
27 humanizer.core.fa@2.14.1
28 humanizer.core.fi-fi@2.14.1
29 humanizer.core.fr-be@2.14.1
30 humanizer.core.fr@2.14.1
31 humanizer.core.he@2.14.1
32 humanizer.core.hr@2.14.1
33 humanizer.core.hu@2.14.1
34 humanizer.core.hy@2.14.1
35 humanizer.core.id@2.14.1
36 humanizer.core.is@2.14.1
37 humanizer.core.it@2.14.1
38 humanizer.core.ja@2.14.1
39 humanizer.core.ko-kr@2.14.1
40 humanizer.core.ku@2.14.1
41 humanizer.core.lv@2.14.1
42 humanizer.core.ms-my@2.14.1
43 humanizer.core.mt@2.14.1
44 humanizer.core.nb-no@2.14.1
45 humanizer.core.nb@2.14.1
46 humanizer.core.nl@2.14.1
47 humanizer.core.pl@2.14.1
48 humanizer.core.pt@2.14.1
49 humanizer.core.ro@2.14.1
50 humanizer.core.ru@2.14.1
51 humanizer.core.sk@2.14.1
52 humanizer.core.sl@2.14.1
53 humanizer.core.sr-latn@2.14.1
54 humanizer.core.sr@2.14.1
55 humanizer.core.sv@2.14.1
56 humanizer.core.th-th@2.14.1
57 humanizer.core.tr@2.14.1
58 humanizer.core.uk@2.14.1
59 humanizer.core.uz-cyrl-uz@2.14.1
60 humanizer.core.uz-latn-uz@2.14.1
61 humanizer.core.vi@2.14.1
62 humanizer.core.zh-cn@2.14.1
63 humanizer.core.zh-hans@2.14.1
64 humanizer.core.zh-hant@2.14.1
65 humanizer.core@2.14.1
66 humanizer@2.14.1
67 jetbrains.annotations@2023.3.0
68 managed-midi@1.10.1
69 markdig@0.23.0
70 messagepack.annotations@2.5.140
71 messagepack.annotations@2.5.187
72 messagepack@2.5.140
73 messagepack@2.5.187
74 microsoft.aspnetcore.connections.abstractions@7.0.15
75 microsoft.aspnetcore.connections.abstractions@8.0.10
76 microsoft.aspnetcore.http.connections.client@7.0.15
77 microsoft.aspnetcore.http.connections.client@8.0.10
78 microsoft.aspnetcore.http.connections.common@7.0.15
79 microsoft.aspnetcore.http.connections.common@8.0.10
80 microsoft.aspnetcore.signalr.client.core@7.0.15
81 microsoft.aspnetcore.signalr.client.core@8.0.10
82 microsoft.aspnetcore.signalr.client@7.0.15
83 microsoft.aspnetcore.signalr.client@8.0.10
84 microsoft.aspnetcore.signalr.common@7.0.15
85 microsoft.aspnetcore.signalr.common@8.0.10
86 microsoft.aspnetcore.signalr.protocols.json@7.0.15
87 microsoft.aspnetcore.signalr.protocols.json@8.0.10
88 microsoft.aspnetcore.signalr.protocols.messagepack@7.0.15
89 microsoft.aspnetcore.signalr.protocols.messagepack@8.0.10
90 microsoft.aspnetcore.signalr.protocols.newtonsoftjson@7.0.15
91 microsoft.aspnetcore.signalr.protocols.newtonsoftjson@8.0.10
92 microsoft.codeanalysis.bannedapianalyzers@3.3.4
93 microsoft.csharp@4.5.0
94 microsoft.csharp@4.7.0
95 microsoft.data.sqlite.core@7.0.12
96 microsoft.data.sqlite.core@8.0.10
97 microsoft.diagnostics.netcore.client@0.2.61701
98 microsoft.diagnostics.runtime@2.0.161401
99 microsoft.dotnet.platformabstractions@2.0.3
100 microsoft.extensions.configuration.abstractions@7.0.0
101 microsoft.extensions.configuration.abstractions@8.0.0
102 microsoft.extensions.dependencyinjection.abstractions@6.0.0
103 microsoft.extensions.dependencyinjection.abstractions@6.0.0-rc.1.21451.13
104 microsoft.extensions.dependencyinjection.abstractions@7.0.0
105 microsoft.extensions.dependencyinjection.abstractions@8.0.0
106 microsoft.extensions.dependencyinjection.abstractions@8.0.2
107 microsoft.extensions.dependencyinjection@6.0.0-rc.1.21451.13
108 microsoft.extensions.dependencyinjection@7.0.0
109 microsoft.extensions.dependencyinjection@8.0.1
110 microsoft.extensions.dependencymodel@2.0.3
111 microsoft.extensions.features@7.0.15
112 microsoft.extensions.features@8.0.10
113 microsoft.extensions.logging.abstractions@7.0.0
114 microsoft.extensions.logging.abstractions@7.0.1
115 microsoft.extensions.logging.abstractions@8.0.0
116 microsoft.extensions.logging.abstractions@8.0.2
117 microsoft.extensions.logging@7.0.0
118 microsoft.extensions.logging@8.0.1
119 microsoft.extensions.objectpool@5.0.11
120 microsoft.extensions.options@6.0.0
121 microsoft.extensions.options@7.0.0
122 microsoft.extensions.options@7.0.1
123 microsoft.extensions.options@8.0.2
124 microsoft.extensions.primitives@6.0.0
125 microsoft.extensions.primitives@7.0.0
126 microsoft.extensions.primitives@8.0.0
127 microsoft.net.stringtools@17.6.3
128 microsoft.netcore.platforms@1.0.1
129 microsoft.netcore.platforms@1.1.0
130 microsoft.netcore.platforms@2.0.0
131 microsoft.netcore.platforms@5.0.0
132 microsoft.netcore.targets@1.0.1
133 microsoft.netcore.targets@1.1.0
134 microsoft.toolkit.highperformance@7.1.2
135 microsoft.win32.primitives@4.3.0
136 microsoft.win32.registry@4.5.0
137 microsoft.win32.registry@5.0.0
138 mongodb.bson@2.19.1
139 nativelibraryloader@1.0.13
140 netstandard.library@1.6.1
141 netstandard.library@2.0.0
142 newtonsoft.json@13.0.1
143 newtonsoft.json@13.0.3
144 nuget.common@5.11.0
145 nuget.configuration@5.11.0
146 nuget.dependencyresolver.core@5.11.0
147 nuget.frameworks@5.11.0
148 nuget.librarymodel@5.11.0
149 nuget.packaging@5.11.0
150 nuget.projectmodel@5.11.0
151 nuget.protocol@5.11.0
152 nuget.versioning@5.11.0
153 nuget.versioning@6.10.1
154 nuget.versioning@6.12.1
155 nunit@3.14.0
156 opentabletdriver.configurations@0.6.4
157 opentabletdriver.native@0.6.4
158 opentabletdriver.plugin@0.6.4
159 opentabletdriver@0.6.4
160 polysharp@1.10.0
161 ppy.localisationanalyser@2024.802.0
162 ppy.managedbass.fx@2022.1216.0
163 ppy.managedbass.mix@2022.1216.0
164 ppy.managedbass.wasapi@2022.1216.0
165 ppy.managedbass@2022.1216.0
166 ppy.osu.framework.nativelibs@2024.809.1-nativelibs
167 ppy.osu.framework.sourcegeneration@2023.720.0
168 ppy.osu.framework@2024.1009.0
169 ppy.osu.framework@2024.1115.0
170 ppy.osu.game.resources@2024.1003.0
171 ppy.osu.game.resources@2024.1106.0
172 ppy.osutk.ns20@1.0.211
173 ppy.sdl2-cs@1.0.741-alpha
174 ppy.sdl3-cs@2024.1022.0
175 ppy.sdl3-cs@2024.916.0
176 ppy.veldrid.metalbindings@4.9.62-gca0239da6b
177 ppy.veldrid.openglbindings@4.9.62-gca0239da6b
178 ppy.veldrid.spirv@1.0.15-gfbb03d21c2
179 ppy.veldrid@4.9.62-gca0239da6b
180 ppy.vk@1.0.26
181 realm.platformhelpers@11.5.0
182 realm@11.5.0
183 remotion.linq@2.2.0
184 runtime.any.system.collections@4.3.0
185 runtime.any.system.diagnostics.tools@4.3.0
186 runtime.any.system.diagnostics.tracing@4.3.0
187 runtime.any.system.globalization.calendars@4.3.0
188 runtime.any.system.globalization@4.3.0
189 runtime.any.system.io@4.3.0
190 runtime.any.system.reflection.extensions@4.3.0
191 runtime.any.system.reflection.primitives@4.3.0
192 runtime.any.system.reflection@4.3.0
193 runtime.any.system.resources.resourcemanager@4.3.0
194 runtime.any.system.runtime.handles@4.3.0
195 runtime.any.system.runtime.interopservices@4.3.0
196 runtime.any.system.runtime@4.3.0
197 runtime.any.system.text.encoding.extensions@4.3.0
198 runtime.any.system.text.encoding@4.3.0
199 runtime.any.system.threading.tasks@4.3.0
200 runtime.any.system.threading.timer@4.3.0
201 runtime.debian.8-x64.runtime.native.system.security.cryptography.openssl@4.3.0
202 runtime.fedora.23-x64.runtime.native.system.security.cryptography.openssl@4.3.0
203 runtime.fedora.24-x64.runtime.native.system.security.cryptography.openssl@4.3.0
204 runtime.native.system.io.compression@4.3.0
205 runtime.native.system.net.http@4.3.0
206 runtime.native.system.net.security@4.3.0
207 runtime.native.system.security.cryptography.apple@4.3.0
208 runtime.native.system.security.cryptography.openssl@4.3.0
209 runtime.native.system@4.0.0
210 runtime.native.system@4.3.0
211 runtime.opensuse.13.2-x64.runtime.native.system.security.cryptography.openssl@4.3.0
212 runtime.opensuse.42.1-x64.runtime.native.system.security.cryptography.openssl@4.3.0
213 runtime.osx.10.10-x64.runtime.native.system.security.cryptography.apple@4.3.0
214 runtime.osx.10.10-x64.runtime.native.system.security.cryptography.openssl@4.3.0
215 runtime.rhel.7-x64.runtime.native.system.security.cryptography.openssl@4.3.0
216 runtime.ubuntu.14.04-x64.runtime.native.system.security.cryptography.openssl@4.3.0
217 runtime.ubuntu.16.04-x64.runtime.native.system.security.cryptography.openssl@4.3.0
218 runtime.ubuntu.16.10-x64.runtime.native.system.security.cryptography.openssl@4.3.0
219 runtime.unix.microsoft.win32.primitives@4.3.0
220 runtime.unix.system.console@4.3.0
221 runtime.unix.system.diagnostics.debug@4.3.0
222 runtime.unix.system.io.filesystem@4.3.0
223 runtime.unix.system.net.primitives@4.3.0
224 runtime.unix.system.net.sockets@4.3.0
225 runtime.unix.system.private.uri@4.3.0
226 runtime.unix.system.runtime.extensions@4.3.0
227 sentry@4.13.0
228 sentry@4.3.0
229 sharpcompress@0.36.0
230 sharpcompress@0.38.0
231 sharpfnt@2.0.0
232 sharpgen.runtime.com@2.0.0-beta.13
233 sharpgen.runtime@2.0.0-beta.13
234 sixlabors.imagesharp@3.1.5
235 sqlitepclraw.bundle_e_sqlite3@2.1.10
236 sqlitepclraw.bundle_e_sqlite3@2.1.8
237 sqlitepclraw.core@2.1.10
238 sqlitepclraw.core@2.1.4
239 sqlitepclraw.core@2.1.6
240 sqlitepclraw.core@2.1.8
241 sqlitepclraw.lib.e_sqlite3@2.1.10
242 sqlitepclraw.lib.e_sqlite3@2.1.8
243 sqlitepclraw.provider.e_sqlite3@2.1.10
244 sqlitepclraw.provider.e_sqlite3@2.1.8
245 stbisharp@1.1.0
246 system.appcontext@4.1.0
247 system.appcontext@4.3.0
248 system.buffers@4.3.0
249 system.buffers@4.5.1
250 system.collections.concurrent@4.3.0
251 system.collections.immutable@1.7.1
252 system.collections@4.0.11
253 system.collections@4.3.0
254 system.componentmodel.annotations@5.0.0
255 system.console@4.3.0
256 system.diagnostics.debug@4.0.11
257 system.diagnostics.debug@4.3.0
258 system.diagnostics.diagnosticsource@4.3.0
259 system.diagnostics.tools@4.3.0
260 system.diagnostics.tracing@4.3.0
261 system.dynamic.runtime@4.0.11
262 system.dynamic.runtime@4.3.0
263 system.formats.asn1@5.0.0
264 system.globalization.calendars@4.3.0
265 system.globalization.extensions@4.3.0
266 system.globalization@4.0.11
267 system.globalization@4.3.0
268 system.io.compression.zipfile@4.3.0
269 system.io.compression@4.3.0
270 system.io.filesystem.primitives@4.3.0
271 system.io.filesystem@4.0.1
272 system.io.filesystem@4.3.0
273 system.io.packaging@8.0.1
274 system.io.pipelines@7.0.0
275 system.io.pipelines@8.0.0
276 system.io@4.1.0
277 system.io@4.3.0
278 system.linq.expressions@4.1.0
279 system.linq.expressions@4.3.0
280 system.linq.queryable@4.0.1
281 system.linq@4.1.0
282 system.linq@4.3.0
283 system.memory@4.5.3
284 system.memory@4.5.4
285 system.memory@4.5.5
286 system.net.http@4.3.0
287 system.net.nameresolution@4.3.0
288 system.net.primitives@4.3.0
289 system.net.security@4.3.0
290 system.net.sockets@4.3.0
291 system.net.webheadercollection@4.3.0
292 system.net.websockets.client@4.3.2
293 system.net.websockets@4.3.0
294 system.numerics.tensors@8.0.0
295 system.objectmodel@4.0.12
296 system.objectmodel@4.3.0
297 system.private.uri@4.3.0
298 system.reflection.emit.ilgeneration@4.0.1
299 system.reflection.emit.ilgeneration@4.3.0
300 system.reflection.emit.lightweight@4.0.1
301 system.reflection.emit.lightweight@4.3.0
302 system.reflection.emit@4.0.1
303 system.reflection.emit@4.3.0
304 system.reflection.extensions@4.0.1
305 system.reflection.extensions@4.3.0
306 system.reflection.metadata@1.8.1
307 system.reflection.primitives@4.0.1
308 system.reflection.primitives@4.3.0
309 system.reflection.typeextensions@4.1.0
310 system.reflection.typeextensions@4.3.0
311 system.reflection@4.1.0
312 system.reflection@4.3.0
313 system.resources.resourcemanager@4.0.1
314 system.resources.resourcemanager@4.3.0
315 system.runtime.compilerservices.unsafe@4.7.1
316 system.runtime.compilerservices.unsafe@6.0.0
317 system.runtime.compilerservices.unsafe@6.0.0-rc.1.21451.13
318 system.runtime.extensions@4.1.0
319 system.runtime.extensions@4.3.0
320 system.runtime.handles@4.3.0
321 system.runtime.interopservices.runtimeinformation@4.0.0
322 system.runtime.interopservices.runtimeinformation@4.3.0
323 system.runtime.interopservices@4.3.0
324 system.runtime.numerics@4.3.0
325 system.runtime@4.1.0
326 system.runtime@4.3.0
327 system.security.accesscontrol@4.5.0
328 system.security.accesscontrol@5.0.0
329 system.security.claims@4.3.0
330 system.security.cryptography.algorithms@4.3.0
331 system.security.cryptography.cng@4.3.0
332 system.security.cryptography.cng@5.0.0
333 system.security.cryptography.csp@4.3.0
334 system.security.cryptography.encoding@4.3.0
335 system.security.cryptography.openssl@4.3.0
336 system.security.cryptography.pkcs@5.0.0
337 system.security.cryptography.primitives@4.3.0
338 system.security.cryptography.protecteddata@4.4.0
339 system.security.cryptography.x509certificates@4.3.0
340 system.security.principal.windows@4.3.0
341 system.security.principal.windows@4.5.0
342 system.security.principal.windows@5.0.0
343 system.security.principal@4.3.0
344 system.text.encoding.extensions@4.3.0
345 system.text.encoding@4.0.11
346 system.text.encoding@4.3.0
347 system.text.regularexpressions@4.3.0
348 system.threading.channels@6.0.0
349 system.threading.channels@7.0.0
350 system.threading.channels@8.0.0
351 system.threading.tasks.extensions@4.3.0
352 system.threading.tasks@4.0.11
353 system.threading.tasks@4.3.0
354 system.threading.threadpool@4.3.0
355 system.threading.timer@4.3.0
356 system.threading@4.0.11
357 system.threading@4.3.0
358 system.xml.readerwriter@4.3.0
359 system.xml.xdocument@4.3.0
360 taglibsharp@2.3.0
361 velopack@0.0.630-g9c52e40
362 velopack@0.0.915
363 vortice.d3dcompiler@2.4.2
364 vortice.direct3d11@2.4.2
365 vortice.directx@2.4.2
366 vortice.dxgi@2.4.2
367 vortice.mathematics@1.4.25
368 zstdsharp.port@0.7.4
369 zstdsharp.port@0.8.1
372 inherit dotnet-pkg desktop xdg
374 DESCRIPTION="rhythm is just a *click* away! "
375 HOMEPAGE="
376 https://osu.ppy.sh
377 https://github.com/ppy/osu
380 SRC_URI="
381 https://github.com/ppy/osu/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
382 ${NUGET_URIS}
384 S="${WORKDIR}/osu-${PV}"
385 LICENSE="MIT CC-BY-NC-4.0"
386 # Dependent NuGet licenses
387 LICENSE+="
388 Apache-2.0 BSD-2 LGPL-2.1 LGPL-3+ MIT
390 SLOT="0"
391 # updtream supported runtime:
392 # linux-{,musl-}{arm,arm64,x64,x86}
393 # only tested on linux-x64
394 KEYWORDS="~amd64"
396 DEPEND="
397 virtual/dotnet-sdk:8.0
399 RDEPEND="
400 ${DEPEND}
401 dev-util/desktop-file-utils
402 media-libs/alsa-lib
403 media-video/ffmpeg
404 media-libs/libsdl2
405 virtual/opengl
407 BDEPEND="${DEPEND}"
409 DOTNET_PKG_PROJECTS=( "${S}/osu.Desktop/osu.Desktop.csproj" )
411 DOCS=( README.md )
413 src_configure() {
414 dotnet-pkg-base_info
415 dotnet-pkg_foreach-project dotnet-pkg-base_restore
416 # skip **dotnet-pkg-base_foreach-solution** here
417 # avoid requiring non-linux workloads
420 src_compile() {
421 DOTNET_PKG_BUILD_EXTRA_ARGS+=(
422 -f net8.0
423 -p:Version="${PV}"
425 dotnet-pkg_src_compile
428 src_install() {
429 dotnet-pkg-base_install
430 dotnet-pkg-base_append-launchervar "OSU_EXTERNAL_UPDATE_PROVIDER=\"1\""
431 dotnet-pkg-base_dolauncher "/usr/share/${P}/osu!" osu-lazer
433 newicon -s 128 assets/lazer-nuget.png osu-lazer.png
434 newicon -s 1024 assets/lazer.png osu-lazer.png
435 domenu "${FILESDIR}/osu-lazer.desktop"
437 insinto "/usr/share/mime/packages"
438 doins "${FILESDIR}/x-osu-lazer.xml"
440 einstalldocs