1 # Copyright 2022-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit xdg desktop unpacker
8 DESCRIPTION
="The official unity tool for manager Unity Engines and projects"
9 HOMEPAGE
="https://unity.com/"
10 SRC_URI
="https://hub.unity3d.com/linux/repos/deb/pool/main/u/unity/unityhub_amd64/${PN}-amd64-${PV}.deb"
16 IUSE
="+appindicator legacy"
17 RESTRICT
="mirror strip"
23 dev-libs/libayatana-appindicator
24 x11-misc/appmenu-gtk-module[gtk2]
29 dev-util/lttng-ust:0/2.12
32 || ( <dev-libs/openssl-3 dev-libs/openssl-compat )
37 unpack_deb
${PN}-amd64-${PV}.deb
41 doins
-r "${S}/opt/unityhub"
42 dosym
-r /opt
/unityhub
/unityhub
/usr
/bin
/unityhub
43 for si
in 16 32 48 64 128 256 512; do
44 doicon
-s ${si} usr/share/icons/hicolor/${si}x${si}/apps/${PN}.png
46 domenu
"${WORKDIR}/usr/share/applications/unityhub.desktop"
47 fperms
0755 -R "/opt/unityhub"