1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 PYTHON_COMPAT
=( python3_
{12.
.13} )
7 inherit python-r1 autotools optfeature xdg
9 DESCRIPTION
="Standalone lyrics fetcher/displayer (windowed and OSD mode)."
10 HOMEPAGE
="https://github.com/osdlyrics/osdlyrics"
15 if [[ "${PV}" == 9999 ]]; then
17 EGIT_REPO_URI
="https://github.com/osdlyrics/osdlyrics.git"
20 SRC_URI
="https://github.com/osdlyrics/osdlyrics/archive/${PV}.tar.gz -> ${P}.tar.gz"
23 IUSE
="gnome indicator"
24 REQUIRED_USE
="${PYTHON_REQUIRED_USE}"
30 x11-themes/hicolor-icon-theme
33 dev-util/desktop-file-utils
34 dev-python/chardet[${PYTHON_USEDEP}]
35 dev-python/dbus-python[${PYTHON_USEDEP}]
36 dev-python/pygobject[${PYTHON_USEDEP}]
37 dev-python/pycurl[${PYTHON_USEDEP}]
38 gnome? ( dev-libs/gobject-introspection )
39 indicator? ( dev-libs/libayatana-appindicator )
57 --prefix="${EPREFIX}/usr" PYTHON
="${PYTHON}"
58 $
(use_enable indicator appindicator
)
62 python_foreach_impl run_in_build_dir configuring
66 python_foreach_impl run_in_build_dir default
70 python_foreach_impl run_in_build_dir default
75 if has_version media-sound
/mpd
; then
76 optfeature
"to interface with MPD" dev-python
/python-mpd2