1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
7 DESCRIPTION="A lightweight Spotify client using YouTube as audio source"
8 HOMEPAGE="https://github.com/KRTirtho/spotube"
9 SRC_URI="https://github.com/KRTirtho/spotube/releases/download/v${PV}/spotube-linux-${PV}-x86_64.tar.xz"
21 >=media-video/mpv-0.38.0-r1
22 >=dev-libs/libayatana-appindicator-0.5.92
30 dosym -r /opt/spotube/spotube /usr/bin/spotube
31 doins "${S}/spotube-logo.png"
32 sed -i -e 's|^Exec=.*|Exec=/opt/spotube/spotube|' \
33 -i -e 's|^Icon=.*|Icon=/opt/spotube/spotube-logo.png|' \
34 "${S}"/spotube.desktop || die
35 for i in 16 32 64 128 256; do
36 doicon -s "$i" "${S}"/spotube-logo.png
38 domenu "${S}/spotube.desktop"
39 patchelf --replace-needed "libappindicator3.so.1" "libayatana-appindicator3.so.1" \
40 "${ED}/opt/spotube/lib/libtray_manager_plugin.so" || die