www-client/thorium-browser-bin: new package, add 128.0.6613.189
[gentoo-zh.git] / media-sound / ytmdesktop-bin / ytmdesktop-bin-2.0.6.ebuild
blob65addebd587a3150641d6e5dda72d547f605e291
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit unpacker desktop xdg
8 MY_PN="${PN/-bin/}"
9 D_PN="youtube-music-desktop-app"
10 MY_PR="${PR/r/}"
11 MY_P="${D_PN}-${PVR}"
13 DESCRIPTION="A Desktop App for YouTube Music"
14 HOMEPAGE="https://github.com/ytmdesktop/ytmdesktop"
15 SRC_URI="https://github.com/ytmdesktop/ytmdesktop/releases/download/v${PV}/${D_PN}_${PV}_amd64.deb -> ${MY_P}.deb"
17 S="${WORKDIR}"
19 LICENSE="MIT"
20 SLOT="0"
22 KEYWORDS="~amd64"
24 RDEPEND="
25 app-accessibility/at-spi2-core:2
26 app-crypt/libsecret
27 dev-libs/nss
28 x11-misc/xdg-utils
29 x11-libs/gtk+:3
30 x11-libs/libnotify
31 x11-libs/libXtst
34 RESTRICT="mirror"
36 QA_PREBUILT="
37 chrome-sandbox
38 chrome_crashpad_handler
39 libEGL.so
40 libffmpeg.so
41 libGLESv2.so
42 libvk_swiftshader.so
43 libvulkan.so.1
44 ${D_PN}
47 src_install() {
48 insinto /opt/"${MY_PN}"
49 doins -r usr/lib/${D_PN}/*
51 doicon usr/share/pixmaps/"${D_PN}".png
53 make_desktop_entry "/opt/${MY_PN}/${D_PN}" "YouTube Music Desktop App" "${D_PN}" "AudioVideo;Audio;"
55 make_desktop_entry "/opt/${MY_PN}/${D_PN} --ozone-platform-hint=auto --enable-features=WaylandWindowDecorations --enable-wayland-ime" "YouTube Music Desktop App Wayland" "${D_PN}" "AudioVideo;Audio;"
57 local f
58 for f in ${QA_PREBUILT}; do
59 fperms +x "/opt/${MY_PN}/${f}"
60 done
62 fperms u+s /opt/"${MY_PN}"/chrome-sandbox