net-dns/ddns-go: add 6.8.0, drop 6.7.7
[gentoo-zh.git] / net-dns / mosdns / mosdns-5.3.3.ebuild
blobe874d43552a7544daa46f97655b17e20f1884f72
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit go-module systemd
7 DESCRIPTION="A DNS forwarder"
8 HOMEPAGE="https://github.com/IrineSistiana/mosdns"
9 SRC_URI="
10 https://github.com/IrineSistiana/mosdns/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
11 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
14 LICENSE="GPL-3"
15 SLOT="5"
16 KEYWORDS="~amd64 ~arm64 ~riscv"
17 IUSE="systemd"
19 src_compile() {
20 local ldflags="\
21 -X main.version=${PV} \
22 -w -s"
23 ego build -o ${P} -trimpath -ldflags "${ldflags}"
24 ./${P} config gen config.yaml
27 src_install() {
28 use systemd && systemd_dounit "${FILESDIR}/mosdns.service"
29 newbin ${P} mosdns
30 insinto /etc/mosdns/
31 doins config.yaml