app-editors/appflowy-bin: add 0.7.5, drop 0.7.4
[gentoo-zh.git] / net-dns / q / q-0.19.2-r1.ebuild
blobca2814806f5f4ea057e6bf4d9292a75a9c26f00e
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit go-module
6 GIT_COMMIT=0ca9b8b13fc69121144d85365c16b3e21508ffc3
8 DESCRIPTION="A tiny command line DNS client with support for UDP, TCP, DoT, DoH, DoQ and ODoH"
9 HOMEPAGE="https://github.com/natesales/q"
11 SRC_URI="
12 https://github.com/natesales/q/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
13 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
16 LICENSE="GPL-3"
17 SLOT="0"
18 KEYWORDS="~amd64 ~arm64"
20 src_compile() {
21 local ldflags="\
22 -X main.version=${PV} \
23 -X main.commit=${GIT_COMMIT} \
24 -X main.date=$(date -u +%Y-%m-%dT%H:%M:%SZ) \
25 -w -s"
26 ego build -o ${P} -trimpath -ldflags "${ldflags}"
29 src_install() {
30 newbin ${P} q-dns