www-client/thorium-browser-bin: new package, add 128.0.6613.189
[gentoo-zh.git] / net-misc / pcmanx-gtk2 / pcmanx-gtk2-9999.ebuild
blob5c742ed81400e4595cfdc4bd9b893cf0249b62b1
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools flag-o-matic git-r3
8 DESCRIPTION="PCMan is a gtk+ based free BBS client"
9 HOMEPAGE="https://github.com/pcman-bbs/pcmanx"
11 EGIT_REPO_URI="https://github.com/pcman-bbs/pcmanx.git"
13 SLOT="0"
14 LICENSE="GPL-2"
15 IUSE="+libnotify +proxy iplookup +wget"
17 COMMON_DEPEND="
18 libnotify? ( x11-libs/libnotify )
19 x11-libs/libXft
20 >=x11-libs/gtk+-2.4:2
23 RDEPEND="
24 ${COMMON_DEPEND}
25 wget? ( net-misc/wget )
28 DEPEND="
29 ${COMMON_DEPEND}
30 dev-util/intltool
31 sys-devel/gettext
34 DOCS=( TODO README.md NEWS ChangeLog AUTHORS )
36 src_prepare() {
37 [[ ! -e ChangeLog && -e ./build/changelog.sh ]] && \
38 ./build/changelog.sh > ChangeLog
40 eautoreconf
42 # this flag crashes CTermData::memset16()
43 filter-flags -ftree-vectorize
44 eapply_user
47 src_configure() {
48 econf $(use_enable proxy) \
49 $(use_enable libnotify) \
50 $(use_enable wget)\
51 $(use_enable iplookup)